<!DOCTYPE html>
<html>
<head>
<meta charset="utf-8">
<meta http-equiv="X-UA-Compatible" content="IE=edge">
<meta property="fb:pages" content="206873672715222" />
<meta name="viewport" content="width=device-width, initial-scale=1.0">
<link href='https://fonts.googleapis.com/css?family=Montserrat:400,700|Open+Sans:400,300,600,400italic,700' rel='stylesheet' type='text/css'>
<script>(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src='https://www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);})(window,document,'script','dataLayer','GTM-MSX4CLH');</script>
<style type="text/css">
					.heateor_sss_button_instagram span.heateor_sss_svg,a.heateor_sss_instagram span.heateor_sss_svg{background:radial-gradient(circle at 30% 107%,#fdf497 0,#fdf497 5%,#fd5949 45%,#d6249f 60%,#285aeb 90%)}
											.heateor_sss_horizontal_sharing .heateor_sss_svg,.heateor_sss_standard_follow_icons_container .heateor_sss_svg{
							color: #fff;
						border-width: 0px;
			border-style: solid;
			border-color: transparent;
		}
					.heateor_sss_horizontal_sharing .heateorSssTCBackground{
				color:#666;
			}
					.heateor_sss_horizontal_sharing span.heateor_sss_svg:hover,.heateor_sss_standard_follow_icons_container span.heateor_sss_svg:hover{
						border-color: transparent;
		}
		.heateor_sss_vertical_sharing span.heateor_sss_svg,.heateor_sss_floating_follow_icons_container span.heateor_sss_svg{
							color: #fff;
						border-width: 0px;
			border-style: solid;
			border-color: transparent;
		}
				.heateor_sss_vertical_sharing .heateorSssTCBackground{
			color:#666;
		}
						.heateor_sss_vertical_sharing span.heateor_sss_svg:hover,.heateor_sss_floating_follow_icons_container span.heateor_sss_svg:hover{
						border-color: transparent;
		}
		@media screen and (max-width:783px) {.heateor_sss_vertical_sharing{display:none!important}}div.heateor_sss_mobile_footer{display:none;}@media screen and (max-width:783px){div.heateor_sss_bottom_sharing .heateorSssTCBackground{background-color:white}div.heateor_sss_bottom_sharing{width:100%!important;left:0!important;}div.heateor_sss_bottom_sharing a{width:16.666666666667% !important;}div.heateor_sss_bottom_sharing .heateor_sss_svg{width: 100% !important;}div.heateor_sss_bottom_sharing div.heateorSssTotalShareCount{font-size:1em!important;line-height:28px!important}div.heateor_sss_bottom_sharing div.heateorSssTotalShareText{font-size:.7em!important;line-height:0px!important}div.heateor_sss_mobile_footer{display:block;height:40px;}.heateor_sss_bottom_sharing{padding:0!important;display:block!important;width:auto!important;bottom:-2px!important;top: auto!important;}.heateor_sss_bottom_sharing .heateor_sss_square_count{line-height:inherit;}.heateor_sss_bottom_sharing .heateorSssSharingArrow{display:none;}.heateor_sss_bottom_sharing .heateorSssTCBackground{margin-right:1.1em!important}}		</style>

<title>How to Install Vue CLI on Ubuntu 20.04 | LinuxCloudVPS Blog</title>
<meta name="description" content="VueJS is a popular JavaScript framework for building interactive web application user interfaces. It builds on top of standard HTML, CSS, and JavaScript, and is very easy to integrate with other projects and libraries. Vue CLI is a complete Vue development package. In this tutorial, we will show you how to install Vue CLI and" />
<meta name="robots" content="max-image-preview:large" />
<link rel="canonical" href="https://www.linuxcloudvps.com/blog/how-to-install-vue-cli-on-ubuntu-20-04/" />
<meta property="og:locale" content="en_US" />
<meta property="og:site_name" content="LinuxCloudVPS Blog |" />
<meta property="og:type" content="article" />
<meta property="og:title" content="How to Install Vue CLI on Ubuntu 20.04 | LinuxCloudVPS Blog" />
<meta property="og:description" content="VueJS is a popular JavaScript framework for building interactive web application user interfaces. It builds on top of standard HTML, CSS, and JavaScript, and is very easy to integrate with other projects and libraries. Vue CLI is a complete Vue development package. In this tutorial, we will show you how to install Vue CLI and" />
<meta property="og:url" content="https://www.linuxcloudvps.com/blog/how-to-install-vue-cli-on-ubuntu-20-04/" />
<meta property="article:published_time" content="2022-05-30T17:30:00+00:00" />
<meta property="article:modified_time" content="2022-05-12T09:59:37+00:00" />
<meta name="twitter:card" content="summary" />
<meta name="twitter:title" content="How to Install Vue CLI on Ubuntu 20.04 | LinuxCloudVPS Blog" />
<meta name="twitter:description" content="VueJS is a popular JavaScript framework for building interactive web application user interfaces. It builds on top of standard HTML, CSS, and JavaScript, and is very easy to integrate with other projects and libraries. Vue CLI is a complete Vue development package. In this tutorial, we will show you how to install Vue CLI and" />
<script type="application/ld+json" class="aioseo-schema">
			{"@context":"https:\/\/schema.org","@graph":[{"@type":"WebSite","@id":"https:\/\/www.linuxcloudvps.com\/blog\/#website","url":"https:\/\/www.linuxcloudvps.com\/blog\/","name":"LinuxCloudVPS Blog","inLanguage":"en-US","publisher":{"@id":"https:\/\/www.linuxcloudvps.com\/blog\/#organization"}},{"@type":"Organization","@id":"https:\/\/www.linuxcloudvps.com\/blog\/#organization","name":"LinuxCloudVPS Blog","url":"https:\/\/www.linuxcloudvps.com\/blog\/"},{"@type":"BreadcrumbList","@id":"https:\/\/www.linuxcloudvps.com\/blog\/how-to-install-vue-cli-on-ubuntu-20-04\/#breadcrumblist","itemListElement":[{"@type":"ListItem","@id":"https:\/\/www.linuxcloudvps.com\/blog\/#listItem","position":1,"item":{"@type":"WebPage","@id":"https:\/\/www.linuxcloudvps.com\/blog\/","name":"Home","description":"LinuxCloudVPS.com Blog. Information, tips and tricks, tutorials and more for our Linux Cloud VPS Hosting","url":"https:\/\/www.linuxcloudvps.com\/blog\/"},"nextItem":"https:\/\/www.linuxcloudvps.com\/blog\/how-to-install-vue-cli-on-ubuntu-20-04\/#listItem"},{"@type":"ListItem","@id":"https:\/\/www.linuxcloudvps.com\/blog\/how-to-install-vue-cli-on-ubuntu-20-04\/#listItem","position":2,"item":{"@type":"WebPage","@id":"https:\/\/www.linuxcloudvps.com\/blog\/how-to-install-vue-cli-on-ubuntu-20-04\/","name":"How to Install Vue CLI on Ubuntu 20.04","description":"VueJS is a popular JavaScript framework for building interactive web application user interfaces. It builds on top of standard HTML, CSS, and JavaScript, and is very easy to integrate with other projects and libraries. Vue CLI is a complete Vue development package. In this tutorial, we will show you how to install Vue CLI and","url":"https:\/\/www.linuxcloudvps.com\/blog\/how-to-install-vue-cli-on-ubuntu-20-04\/"},"previousItem":"https:\/\/www.linuxcloudvps.com\/blog\/#listItem"}]},{"@type":"Person","@id":"https:\/\/www.linuxcloudvps.com\/blog\/author\/r0s3admin\/#author","url":"https:\/\/www.linuxcloudvps.com\/blog\/author\/r0s3admin\/","name":"admin"},{"@type":"WebPage","@id":"https:\/\/www.linuxcloudvps.com\/blog\/how-to-install-vue-cli-on-ubuntu-20-04\/#webpage","url":"https:\/\/www.linuxcloudvps.com\/blog\/how-to-install-vue-cli-on-ubuntu-20-04\/","name":"How to Install Vue CLI on Ubuntu 20.04 | LinuxCloudVPS Blog","description":"VueJS is a popular JavaScript framework for building interactive web application user interfaces. It builds on top of standard HTML, CSS, and JavaScript, and is very easy to integrate with other projects and libraries. Vue CLI is a complete Vue development package. In this tutorial, we will show you how to install Vue CLI and","inLanguage":"en-US","isPartOf":{"@id":"https:\/\/www.linuxcloudvps.com\/blog\/#website"},"breadcrumb":{"@id":"https:\/\/www.linuxcloudvps.com\/blog\/how-to-install-vue-cli-on-ubuntu-20-04\/#breadcrumblist"},"author":"https:\/\/www.linuxcloudvps.com\/blog\/author\/r0s3admin\/#author","creator":"https:\/\/www.linuxcloudvps.com\/blog\/author\/r0s3admin\/#author","image":{"@type":"ImageObject","@id":"https:\/\/www.linuxcloudvps.com\/blog\/#mainImage","url":"https:\/\/www.linuxcloudvps.com\/blog\/wp-content\/uploads\/2022\/05\/how-to-install-vue-cli-on-ubuntu-20-04.jpg","width":742,"height":372,"caption":"how to install vue cli on ubuntu 20.04"},"primaryImageOfPage":{"@id":"https:\/\/www.linuxcloudvps.com\/blog\/how-to-install-vue-cli-on-ubuntu-20-04\/#mainImage"},"datePublished":"2022-05-30T17:30:00-05:00","dateModified":"2022-05-12T09:59:37-05:00"},{"@type":"Article","@id":"https:\/\/www.linuxcloudvps.com\/blog\/how-to-install-vue-cli-on-ubuntu-20-04\/#article","name":"How to Install Vue CLI on Ubuntu 20.04 | LinuxCloudVPS Blog","description":"VueJS is a popular JavaScript framework for building interactive web application user interfaces. It builds on top of standard HTML, CSS, and JavaScript, and is very easy to integrate with other projects and libraries. Vue CLI is a complete Vue development package. In this tutorial, we will show you how to install Vue CLI and","inLanguage":"en-US","headline":"How to Install Vue CLI on Ubuntu 20.04","author":{"@id":"https:\/\/www.linuxcloudvps.com\/blog\/author\/r0s3admin\/#author"},"publisher":{"@id":"https:\/\/www.linuxcloudvps.com\/blog\/#organization"},"datePublished":"2022-05-30T17:30:00-05:00","dateModified":"2022-05-12T09:59:37-05:00","articleSection":"Tutorials, Ubuntu, how to install, ubuntu 20.04, vue","mainEntityOfPage":{"@id":"https:\/\/www.linuxcloudvps.com\/blog\/how-to-install-vue-cli-on-ubuntu-20-04\/#webpage"},"isPartOf":{"@id":"https:\/\/www.linuxcloudvps.com\/blog\/how-to-install-vue-cli-on-ubuntu-20-04\/#webpage"},"image":{"@type":"ImageObject","@id":"https:\/\/www.linuxcloudvps.com\/blog\/#articleImage","url":"https:\/\/www.linuxcloudvps.com\/blog\/wp-content\/uploads\/2022\/05\/how-to-install-vue-cli-on-ubuntu-20-04.jpg","width":742,"height":372,"caption":"how to install vue cli on ubuntu 20.04"}}]}
		</script>

<link rel="amphtml" href="https://www.linuxcloudvps.com/blog/how-to-install-vue-cli-on-ubuntu-20-04/amp/" /><meta name="generator" content="AMP for WP 1.0.77.44" /><link rel='dns-prefetch' href='//s.w.org' />
<script type="text/javascript">
window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.1.0\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.1.0\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/www.linuxcloudvps.com\/blog\/wp-includes\/js\/wp-emoji-release.min.js?ver=5.9.3"}};
/*! This file is auto-generated */
!function(e,a,t){var n,r,o,i=a.createElement("canvas"),p=i.getContext&&i.getContext("2d");function s(e,t){var a=String.fromCharCode;p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,e),0,0);e=i.toDataURL();return p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,t),0,0),e===i.toDataURL()}function c(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(o=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},r=0;r<o.length;r++)t.supports[o[r]]=function(e){if(!p||!p.fillText)return!1;switch(p.textBaseline="top",p.font="600 32px Arial",e){case"flag":return s([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])?!1:!s([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!s([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]);case"emoji":return!s([10084,65039,8205,55357,56613],[10084,65039,8203,55357,56613])}return!1}(o[r]),t.supports.everything=t.supports.everything&&t.supports[o[r]],"flag"!==o[r]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[o[r]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(n=t.source||{}).concatemoji?c(n.concatemoji):n.wpemoji&&n.twemoji&&(c(n.twemoji),c(n.wpemoji)))}(window,document,window._wpemojiSettings);
</script>
<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 0.07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='wp-block-library-css' href='https://www.linuxcloudvps.com/blog/wp-includes/css/dist/block-library/style.min.css?ver=5.9.3' type='text/css' media='all' />
<style id='global-styles-inline-css' type='text/css'>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</style>
<link rel='stylesheet' id='heateor_sss_frontend_css-css' href='https://www.linuxcloudvps.com/blog/wp-content/plugins/sassy-social-share/public/css/sassy-social-share-public.css?ver=3.3.42' type='text/css' media='all' />
<link rel='stylesheet' id='wbst-css-css' href='https://www.linuxcloudvps.com/blog/wp-content/themes/lcvps2015/css/lcvps.css' type='text/css' media='all' />
<link rel='stylesheet' id='site-css-css' href='https://www.linuxcloudvps.com/assets/css/style.css' type='text/css' media='all' />
<link rel='stylesheet' id='core3.0-css' href='https://www.linuxcloudvps.com/blog/wp-content/plugins/wp-syntaxhighlighter/syntaxhighlighter3/styles/shCore.css?ver=3.0' type='text/css' media='all' />
<link rel='stylesheet' id='core-Default3.0-css' href='https://www.linuxcloudvps.com/blog/wp-content/plugins/wp-syntaxhighlighter/syntaxhighlighter3/styles/shCoreDefault.css?ver=3.0' type='text/css' media='all' />
<link rel='stylesheet' id='theme-Default3.0-css' href='https://www.linuxcloudvps.com/blog/wp-content/plugins/wp-syntaxhighlighter/syntaxhighlighter3/styles/shThemeDefault.css?ver=3.0' type='text/css' media='all' />
<script type='text/javascript' src='https://www.linuxcloudvps.com/blog/wp-includes/js/jquery/jquery.min.js?ver=3.6.0' id='jquery-core-js'></script>
<script type='text/javascript' src='https://www.linuxcloudvps.com/blog/wp-includes/js/jquery/jquery-migrate.min.js?ver=3.3.2' id='jquery-migrate-js'></script>
<script type='text/javascript' src='https://www.linuxcloudvps.com/blog/wp-content/themes/lcvps2015/js/modernizr-2.6.2.min.js' id='modernizr-js'></script>
<link rel="https://api.w.org/" href="https://www.linuxcloudvps.com/blog/wp-json/" /><link rel="alternate" type="application/json" href="https://www.linuxcloudvps.com/blog/wp-json/wp/v2/posts/1733" /><link rel="alternate" type="application/json+oembed" href="https://www.linuxcloudvps.com/blog/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.linuxcloudvps.com%2Fblog%2Fhow-to-install-vue-cli-on-ubuntu-20-04%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://www.linuxcloudvps.com/blog/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.linuxcloudvps.com%2Fblog%2Fhow-to-install-vue-cli-on-ubuntu-20-04%2F&#038;format=xml" />
<link rel="author" href="https://plus.google.com/109398602334617462972" />

<style type='text/css'>
.syntaxhighlighter,
.syntaxhighlighter a,
.syntaxhighlighter div,
.syntaxhighlighter code,
.syntaxhighlighter table,
.syntaxhighlighter table td,
.syntaxhighlighter table tr,
.syntaxhighlighter table tbody,
.syntaxhighlighter table thead,
.syntaxhighlighter table caption,
.syntaxhighlighter textarea {
font-size: 12px !important; /* Set the font size in pixels */  
font-family: "Consolas", "Bitstream Vera Sans Mono", "Courier New", Courier, monospace !important; /* Set the font type */  
}
.syntaxhighlighter table caption {
/* For Title(Caption) */  
font-size: 14px !important; /* Set the font size in pixels */  
font-family: "Consolas", "Bitstream Vera Sans Mono", "Courier New", Courier, monospace !important; /* Set the font type */  
}
.syntaxhighlighter.nogutter td.code .line {
/* Set the left padding space when no-gutter in ver. 3.0 */  
padding-left: 3px !important;
}
.syntaxhighlighter {
/* For Chrome/Safari(WebKit) */  
/* Hide the superfluous vertical scrollbar in ver. 3.0 */  
overflow-y: hidden !important;
padding: 1px !important;
}
.widget-area.syntaxhighlighter a,
.widget-area.syntaxhighlighter div,
.widget-area.syntaxhighlighter code,
.widget-area.syntaxhighlighter table,
.widget-area.syntaxhighlighter table td,
.widget-area.syntaxhighlighter table tr,
.widget-area.syntaxhighlighter table tbody,
.widget-area.syntaxhighlighter table thead,
.widget-area.syntaxhighlighter table caption,
.widget-area.syntaxhighlighter textarea {
/* For Widget */  
font-size: 14px !important; /* Set the font size in pixels */  
font-family: "Consolas", "Bitstream Vera Sans Mono", "Courier New", Courier, monospace !important; /* Set the font type */  
}
.widget-area table caption {
/* For Widget */  
/* For Title(Caption) */  
font-size: 10px !important; /* Set the font size in pixels */  
font-family: "Consolas", "Bitstream Vera Sans Mono", "Courier New", Courier, monospace !important; /* Set the font type */  
}

.syntaxhighlighter .toolbar {
  display: none !important;
}
</style>

<style type="text/css" id="wp-custom-css">
			/*
You can add your own CSS here.

Click the help icon above to learn more.
*/

section h2 {
font-size: 22px;
}
section h3 {
font-size: 19px;
}
		</style>
</head>
<body class="post-template-default single single-post postid-1733 single-format-standard unknown">
<header>
<nav class="navbar navbar-default navbar-fixed-top" role="navigation">
<div class="container">
<div class="navbar-header">
<a href="https://www.linuxcloudvps.com/index.html" class="navbar-brand"><img alt="LinuxCloudVPS" src="https://www.linuxcloudvps.com/assets/images/logo.png"></a>
<button data-target="#navbar-main" data-toggle="collapse" type="button" class="navbar-toggle">
<span class="icon-bar"></span>
<span class="icon-bar"></span>
<span class="icon-bar"></span>
</button>
</div>
<div id="navbar-main" class="navbar-collapse collapse">
<ul class="nav navbar-nav navbar-right">
<li><a href="https://www.linuxcloudvps.com/aboutus.html">Company</a></li>
<li class="dropdown"><a href="https://www.linuxcloudvps.com/cloud-hosting.html" data-toggle="dropdown" class="dropdown-toggle">Hosting<span class="caret"></span></a>
<ul class="dropdown-menu">
<li><a href="https://www.linuxcloudvps.com/cloud-vps.html">Cloud VPS</a></li>
<li><a href="https://www.linuxcloudvps.com/clientportal/index.php?/affiliates/">Affiliate Program</a></li>
</ul>
</li>
<li class="dropdown"><a href="#" data-toggle="dropdown" class="dropdown-toggle">Domains <span class="caret"></span></a>
<ul class="dropdown-menu">
<li><a href="https://www.linuxcloudvps.com/clientportal/index.php/checkdomain/domain-registration#register">Register New</a></li>
<li><a href="https://www.linuxcloudvps.com/clientportal/index.php/checkdomain/domain-registration#transfer">Transfer Domains</a></li>
</ul>
</li>
<li class="dropdown"><a href="#" data-toggle="dropdown" class="dropdown-toggle">SSL Certs <span class="caret"></span></a>
<ul class="dropdown-menu">
<li class="dropdown-header"><span></span>By brand</li>
<li><a href="https://www.linuxcloudvps.com/ssl-certificates.html">GeoTrust</a></li>
<li><a href="https://www.linuxcloudvps.com/ssl-certificates.html#comodo">Comodo</a></li>
<li><a href="https://www.linuxcloudvps.com/ssl-certificates.html#rapidssl">RapidSSL</a></li>
<li><a href="https://www.linuxcloudvps.com/ssl-certificates.html#symantec">Symantec</a></li>
<li><a href="https://www.linuxcloudvps.com/ssl-certificates.html#thawte">Thawte</a></li>
<li class="dropdown-header">By Type</li>
<li><a href="https://www.linuxcloudvps.com/ssl-certificates-by-type.html">Domain Validation</a></li>
<li><a href="https://www.linuxcloudvps.com/ssl-certificates-by-type.html#organization">Organization Validation</a></li>
<li><a href="https://www.linuxcloudvps.com/ssl-certificates-by-type.html#extended">Extended Validation</a></li>
<li><a href="https://www.linuxcloudvps.com/ssl-certificates-by-type.html#wildcard">Wildcard SSL</a></li>
<li><a href="https://www.linuxcloudvps.com/ssl-certificates-by-type.html#codesigning">Code Signing SSL</a></li>
<li><a href="https://www.linuxcloudvps.com/ssl-certificates-by-type.html#sgs">SCG SSL</a></li>
</ul>
</li>
<li class="hidden-sm dropdown"><a href="#" data-toggle="dropdown" class="dropdown-toggle">Support<span class="caret"></span></a>
<ul class="dropdown-menu">
<li><a href="https://www.linuxcloudvps.com/clientportal/index.php?/tickets/">HelpDesk System</a></li>
<li><a href="https://www.linuxcloudvps.com/clientportal/index.php?/knowledgebase/">Knowledge Base</a></li>
</ul>
</li>
<li><a href="https://www.linuxcloudvps.com/blog/">Blog</a></li>
<li class="button"><a href="https://www.linuxcloudvps.com/clientportal/index.php?/clientarea/">Login</a></li>
</ul>
</div>
</div>
</nav>
</header>
<main class="main blog">
<div class="container">
<div class="row">
<div class="col-xs-12 col-sm-8">
<div id="content" role="main">
<article role="article" id="post_1733" class="post-1733 post type-post status-publish format-standard has-post-thumbnail hentry category-tutorials category-ubuntu tag-how-to-install tag-ubuntu-20-04 tag-vue">
<header>
<h2><a href="https://www.linuxcloudvps.com/blog/how-to-install-vue-cli-on-ubuntu-20-04/">How to Install Vue CLI on Ubuntu 20.04</a></h2>
<p class="meta">
<time class="text-muted" datetime="30-05-2022">30th May 2022</time> /
Category: <a href="https://www.linuxcloudvps.com/blog/category/tutorials/" rel="category tag">Tutorials</a>, <a href="https://www.linuxcloudvps.com/blog/category/ubuntu/" rel="category tag">Ubuntu</a> /
Comments: <a href="https://www.linuxcloudvps.com/blog/how-to-install-vue-cli-on-ubuntu-20-04/#respond">None</a> </p>
</header>
<section>
<div class="post-index-image">
<img width="742" height="372" src="https://www.linuxcloudvps.com/blog/wp-content/uploads/2022/05/how-to-install-vue-cli-on-ubuntu-20-04.jpg" class="attachment-post-thumbnail size-post-thumbnail wp-post-image" alt="how to install vue cli on ubuntu 20.04" srcset="https://www.linuxcloudvps.com/blog/wp-content/uploads/2022/05/how-to-install-vue-cli-on-ubuntu-20-04.jpg 742w, https://www.linuxcloudvps.com/blog/wp-content/uploads/2022/05/how-to-install-vue-cli-on-ubuntu-20-04-470x236.jpg 470w" sizes="(max-width: 742px) 100vw, 742px" /> </div>
<div class='heateorSssClear'></div><div class='heateor_sss_sharing_container heateor_sss_horizontal_sharing' data-heateor-sss-href='https://www.linuxcloudvps.com/blog/how-to-install-vue-cli-on-ubuntu-20-04/'><div class='heateor_sss_sharing_title' style="font-weight:bold">Spread the love</div><div class="heateor_sss_sharing_ul"><a class="heateor_sss_facebook" href="https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Fwww.linuxcloudvps.com%2Fblog%2Fhow-to-install-vue-cli-on-ubuntu-20-04%2F" title="Facebook" rel="nofollow noopener" target="_blank" style="font-size:32px!important;box-shadow:none;display:inline-block;vertical-align:middle"><span class="heateor_sss_svg" style="background-color:#3c589a;width:35px;height:35px;border-radius:999px;display:inline-block;opacity:1;float:left;font-size:32px;box-shadow:none;display:inline-block;font-size:16px;padding:0 4px;vertical-align:middle;background-repeat:repeat;overflow:hidden;padding:0;cursor:pointer;box-sizing:content-box"><svg style="display:block;border-radius:999px;" focusable="false" aria-hidden="true" xmlns="http://www.w3.org/2000/svg" width="100%" height="100%" viewBox="-5 -5 42 42"><path d="M17.78 27.5V17.008h3.522l.527-4.09h-4.05v-2.61c0-1.182.33-1.99 2.023-1.99h2.166V4.66c-.375-.05-1.66-.16-3.155-.16-3.123 0-5.26 1.905-5.26 5.405v3.016h-3.53v4.09h3.53V27.5h4.223z" fill="#fff"></path></svg></span></a><a class="heateor_sss_button_twitter" href="https://twitter.com/intent/tweet?text=How%20to%20Install%20Vue%20CLI%20on%20Ubuntu%2020.04&url=https%3A%2F%2Fwww.linuxcloudvps.com%2Fblog%2Fhow-to-install-vue-cli-on-ubuntu-20-04%2F" title="Twitter" rel="nofollow noopener" target="_blank" style="font-size:32px!important;box-shadow:none;display:inline-block;vertical-align:middle"><span class="heateor_sss_svg heateor_sss_s__default heateor_sss_s_twitter" style="background-color:#55acee;width:35px;height:35px;border-radius:999px;display:inline-block;opacity:1;float:left;font-size:32px;box-shadow:none;display:inline-block;font-size:16px;padding:0 4px;vertical-align:middle;background-repeat:repeat;overflow:hidden;padding:0;cursor:pointer;box-sizing:content-box"><svg style="display:block;border-radius:999px;" focusable="false" aria-hidden="true" xmlns="http://www.w3.org/2000/svg" width="100%" height="100%" viewBox="-4 -4 39 39"><path d="M28 8.557a9.913 9.913 0 0 1-2.828.775 4.93 4.93 0 0 0 2.166-2.725 9.738 9.738 0 0 1-3.13 1.194 4.92 4.92 0 0 0-3.593-1.55 4.924 4.924 0 0 0-4.794 6.049c-4.09-.21-7.72-2.17-10.15-5.15a4.942 4.942 0 0 0-.665 2.477c0 1.71.87 3.214 2.19 4.1a4.968 4.968 0 0 1-2.23-.616v.06c0 2.39 1.7 4.38 3.952 4.83-.414.115-.85.174-1.297.174-.318 0-.626-.03-.928-.086a4.935 4.935 0 0 0 4.6 3.42 9.893 9.893 0 0 1-6.114 2.107c-.398 0-.79-.023-1.175-.068a13.953 13.953 0 0 0 7.55 2.213c9.056 0 14.01-7.507 14.01-14.013 0-.213-.005-.426-.015-.637.96-.695 1.795-1.56 2.455-2.55z" fill="#fff"></path></svg></span></a><a class="heateor_sss_button_linkedin" href="https://www.linkedin.com/shareArticle?mini=true&url=https%3A%2F%2Fwww.linuxcloudvps.com%2Fblog%2Fhow-to-install-vue-cli-on-ubuntu-20-04%2F&title=How%20to%20Install%20Vue%20CLI%20on%20Ubuntu%2020.04" title="Linkedin" rel="nofollow noopener" target="_blank" style="font-size:32px!important;box-shadow:none;display:inline-block;vertical-align:middle"><span class="heateor_sss_svg heateor_sss_s__default heateor_sss_s_linkedin" style="background-color:#0077b5;width:35px;height:35px;border-radius:999px;display:inline-block;opacity:1;float:left;font-size:32px;box-shadow:none;display:inline-block;font-size:16px;padding:0 4px;vertical-align:middle;background-repeat:repeat;overflow:hidden;padding:0;cursor:pointer;box-sizing:content-box"><svg style="display:block;border-radius:999px;" focusable="false" aria-hidden="true" xmlns="http://www.w3.org/2000/svg" width="100%" height="100%" viewBox="0 0 32 32"><path d="M6.227 12.61h4.19v13.48h-4.19V12.61zm2.095-6.7a2.43 2.43 0 0 1 0 4.86c-1.344 0-2.428-1.09-2.428-2.43s1.084-2.43 2.428-2.43m4.72 6.7h4.02v1.84h.058c.56-1.058 1.927-2.176 3.965-2.176 4.238 0 5.02 2.792 5.02 6.42v7.395h-4.183v-6.56c0-1.564-.03-3.574-2.178-3.574-2.18 0-2.514 1.7-2.514 3.46v6.668h-4.187V12.61z" fill="#fff"></path></svg></span></a><a class="heateor_sss_button_pinterest" onclick="javascript:void( (function() {var e=document.createElement('script' );e.setAttribute('type','text/javascript' );e.setAttribute('charset','UTF-8' );e.setAttribute('src','//assets.pinterest.com/js/pinmarklet.js?r='+Math.random()*99999999);document.body.appendChild(e)})());" title="Pinterest" rel="nofollow noopener" style="font-size:32px!important;box-shadow:none;display:inline-block;vertical-align:middle"><span class="heateor_sss_svg heateor_sss_s__default heateor_sss_s_pinterest" style="background-color:#cc2329;width:35px;height:35px;border-radius:999px;display:inline-block;opacity:1;float:left;font-size:32px;box-shadow:none;display:inline-block;font-size:16px;padding:0 4px;vertical-align:middle;background-repeat:repeat;overflow:hidden;padding:0;cursor:pointer;box-sizing:content-box"><svg style="display:block;border-radius:999px;" focusable="false" aria-hidden="true" xmlns="http://www.w3.org/2000/svg" width="100%" height="100%" viewBox="-2 -2 35 35"><path fill="#fff" d="M16.539 4.5c-6.277 0-9.442 4.5-9.442 8.253 0 2.272.86 4.293 2.705 5.046.303.125.574.005.662-.33.061-.231.205-.816.27-1.06.088-.331.053-.447-.191-.736-.532-.627-.873-1.439-.873-2.591 0-3.338 2.498-6.327 6.505-6.327 3.548 0 5.497 2.168 5.497 5.062 0 3.81-1.686 7.025-4.188 7.025-1.382 0-2.416-1.142-2.085-2.545.397-1.674 1.166-3.48 1.166-4.689 0-1.081-.581-1.983-1.782-1.983-1.413 0-2.548 1.462-2.548 3.419 0 1.247.421 2.091.421 2.091l-1.699 7.199c-.505 2.137-.076 4.755-.039 5.019.021.158.223.196.314.077.13-.17 1.813-2.247 2.384-4.324.162-.587.929-3.631.929-3.631.46.876 1.801 1.646 3.227 1.646 4.247 0 7.128-3.871 7.128-9.053.003-3.918-3.317-7.568-8.361-7.568z" /></svg></span></a><a class="heateor_sss_button_reddit" href="https://reddit.com/submit?url=https%3A%2F%2Fwww.linuxcloudvps.com%2Fblog%2Fhow-to-install-vue-cli-on-ubuntu-20-04%2F&title=How%20to%20Install%20Vue%20CLI%20on%20Ubuntu%2020.04" title="Reddit" rel="nofollow noopener" target="_blank" style="font-size:32px!important;box-shadow:none;display:inline-block;vertical-align:middle"><span class="heateor_sss_svg heateor_sss_s__default heateor_sss_s_reddit" style="background-color:#ff5700;width:35px;height:35px;border-radius:999px;display:inline-block;opacity:1;float:left;font-size:32px;box-shadow:none;display:inline-block;font-size:16px;padding:0 4px;vertical-align:middle;background-repeat:repeat;overflow:hidden;padding:0;cursor:pointer;box-sizing:content-box"><svg style="display:block;border-radius:999px;" focusable="false" aria-hidden="true" xmlns="http://www.w3.org/2000/svg" width="100%" height="100%" viewBox="-3.5 -3.5 39 39"><path d="M28.543 15.774a2.953 2.953 0 0 0-2.951-2.949 2.882 2.882 0 0 0-1.9.713 14.075 14.075 0 0 0-6.85-2.044l1.38-4.349 3.768.884a2.452 2.452 0 1 0 .24-1.176l-4.274-1a.6.6 0 0 0-.709.4l-1.659 5.224a14.314 14.314 0 0 0-7.316 2.029 2.908 2.908 0 0 0-1.872-.681 2.942 2.942 0 0 0-1.618 5.4 5.109 5.109 0 0 0-.062.765c0 4.158 5.037 7.541 11.229 7.541s11.22-3.383 11.22-7.541a5.2 5.2 0 0 0-.053-.706 2.963 2.963 0 0 0 1.427-2.51zm-18.008 1.88a1.753 1.753 0 0 1 1.73-1.74 1.73 1.73 0 0 1 1.709 1.74 1.709 1.709 0 0 1-1.709 1.711 1.733 1.733 0 0 1-1.73-1.711zm9.565 4.968a5.573 5.573 0 0 1-4.081 1.272h-.032a5.576 5.576 0 0 1-4.087-1.272.6.6 0 0 1 .844-.854 4.5 4.5 0 0 0 3.238.927h.032a4.5 4.5 0 0 0 3.237-.927.6.6 0 1 1 .844.854zm-.331-3.256a1.726 1.726 0 1 1 1.709-1.712 1.717 1.717 0 0 1-1.712 1.712z" fill="#fff" /></svg></span></a><a class="heateor_sss_more" title="More" rel="nofollow noopener" style="font-size: 32px!important;border:0;box-shadow:none;display:inline-block!important;font-size:16px;padding:0 4px;vertical-align: middle;display:inline;" href="https://www.linuxcloudvps.com/blog/how-to-install-vue-cli-on-ubuntu-20-04/" onclick="event.preventDefault()"><span class="heateor_sss_svg" style="background-color:#ee8e2d;width:35px;height:35px;border-radius:999px;display:inline-block!important;opacity:1;float:left;font-size:32px!important;box-shadow:none;display:inline-block;font-size:16px;padding:0 4px;vertical-align:middle;display:inline;background-repeat:repeat;overflow:hidden;padding:0;cursor:pointer;box-sizing:content-box;" onclick="heateorSssMoreSharingPopup(this, 'https://www.linuxcloudvps.com/blog/how-to-install-vue-cli-on-ubuntu-20-04/', 'How%20to%20Install%20Vue%20CLI%20on%20Ubuntu%2020.04', '' )"><svg xmlns="http://www.w3.org/2000/svg" style="display:block;border-radius:999px;" width="100%" height="100%" viewBox="-4 -4 38 38"><circle cx="10" cy="15" r="3" fill="#fff"></circle><circle cx="20" cy="10" r="3" fill="#fff"></circle><circle cx="20" cy="20" r="3" fill="#fff"></circle><path d="M 10 15 L 20 10 m 0 10 L 10 15" class="heateor_sss_svg_stroke heateor_sss_no_fill" stroke-width="2" stroke="#fff"></path></svg></span></a></div><div class="heateorSssClear"></div></div><div class='heateorSssClear'></div>
<p>VueJS is a popular JavaScript framework for building interactive web application user interfaces. It builds on top of standard HTML, CSS, and JavaScript, and is very easy to integrate with other projects and libraries. Vue CLI is a complete Vue development package.</p>
<p>In this tutorial, we will show you how to install Vue CLI and create a VueJS project on your <a href="https://www.linuxcloudvps.com/ubuntu-cloud-vps.html">Ubuntu 20.04 server</a>.</p>
<span id="more-1733"></span>
<h2>Prerequisites</h2>
<ul><li>A Ubuntu 20.04 VPS with root access enabled or a user with Sudo privileges.</li><li>Install <a href="https://nodejs.org/" target="_blank" rel="noreferrer noopener">Node.js</a> version 8.9 or above (v10+ recommended)</li></ul>
<h2>Step 1: Log in via SSH and Update your System</h2>
<p>First, you will need to log in to your Ubuntu 20.04 server via SSH as the root user:</p>
<pre class="wp-block-preformatted">ssh <a href="/cdn-cgi/l/email-protection" class="__cf_email__" data-cfemail="b2c0ddddc6f2fbe2">[email&#160;protected]</a>_Address -p Port_number</pre>
<p>You will need to replace ‘<strong>IP_Address</strong>’ and ‘<strong>Port_number</strong>’ with your server’s respective IP address and SSH port number. Additionally, replace ‘root’ with the sudo username if necessary.</p>
<p>You have to make sure that all Ubuntu OS packages installed on the server are up to date. Run the following commands to upgrade all installed packages on your server:</p>
<pre class="wp-block-preformatted">apt-get update
apt-get upgrade</pre>
<h2>Step 2. Install Nodejs and NPM</h2>
<p>Vue CLI comes as an NPM package. The first thing you need to make sure of is that Node.js and NPM are available on your system.</p>
<p>By default, the latest version of Node.js is not available in the Ubuntu 20.04 default repository. So you will need to add the Node.js official repository to your system.</p>
<p>Add the Node.js repository with the following command:</p>
<pre class="wp-block-preformatted">curl -sL https://deb.nodesource.com/setup_16.x | bash -</pre>
<p>And install the Node.js from the added repositories running the following command:</p>
<pre class="wp-block-preformatted">sudo apt-get install nodejs</pre>
<p>Once NodeJS has been installed, you can verify the installed version of Node.js with the following command:</p>
<pre class="wp-block-preformatted">node -v</pre>
<p>You should get the following output:</p>
<pre class="wp-block-preformatted">v16.14.2</pre>
<p>Once Node.js is installed, update the NPM to the latest version using the following command:</p>
<pre class="wp-block-preformatted">npm install <a href="/cdn-cgi/l/email-protection" class="__cf_email__" data-cfemail="7c120c113c101d08190f08">[email&#160;protected]</a> -g</pre>
<p>You can now verify the npm version with the following command:</p>
<pre class="wp-block-preformatted">npm -v</pre>
<p>You should get the following output:</p>
<pre class="wp-block-preformatted">8.6.0</pre>
<h2>Step 3. Install Vue CLI</h2>
<p>Now install the <code>Vue CLI</code> package using NPM. This package helps to set all tools required to create a new project in VueJS.</p>
<pre class="wp-block-preformatted">npm install -g @vue/cli</pre>
<p>Check the version with:</p>
<pre class="wp-block-preformatted">vue --version</pre>
<p>You should get the following output:</p>
<pre class="wp-block-preformatted">@vue/cli 5.0.4</pre>
<h2>Step 4: Create your VueJS Application</h2>
<p>You can create your VueJS application with the following command:</p>
<pre class="wp-block-preformatted">vue create my-project</pre>
<p>You&#8217;ll be prompted with the following code:</p>
<pre class="wp-block-preformatted">Vue CLI v5.0.4
? Please pick a preset: (Use arrow keys)
❯ Default ([Vue 3] babel, eslint)
Default ([Vue 2] babel, eslint)
Manually select features</pre>
<p>You can choose the default preset Vue 2 or Vue 3 project which comes with a basic <code>Babel + ESLint</code> setup or select “<code>Manually select features</code>” to pick the features you need.</p>
<p>Once the installation is finished, you should get the following output:</p>
<pre class="wp-block-preformatted">&amp;#x1f389;  Successfully created project my-project.
&amp;#x1f449;  Get started with the following commands:

 $ cd my-project
 $ npm run serve
</pre>
<p>Change the directory to the VueJS application:</p>
<pre class="wp-block-preformatted">cd my-project</pre>
<p>Now you need to start your VueJS application with the following command:</p>
<pre class="wp-block-preformatted">npm run serve</pre>
<p>You should get the following output:</p>
<pre class="wp-block-preformatted"> DONE  Compiled successfully in 10295ms


  App running at:
  - Local:   http://localhost:8080/
  - Network: http://192.168.1.10:8080/

  Note that the development build is not optimized.
  To create a production build, run npm run build.
</pre>
<p>By default, the VueJS application starts on port <code>8080</code>.</p>
<h2>Step 5: Create a Systemd Service File for VueJS App</h2>
<p>Next, you need to create a systemd service file to manage the VueJS service. You can create it with the following command:</p>
<pre class="wp-block-preformatted">nano /lib/systemd/system/vuejs.service</pre>
<p>Add the following lines:</p>
<pre class="wp-block-preformatted">[Service]
Type=simple
User=root
Restart=on-failure
WorkingDirectory=/root/my-project
ExecStart=npm run serve -- --port=8080

[Install]
WantedBy=default.target</pre>
<p>Save and close the file, then reload the <strong>systemd</strong> service with the following command:</p>
<pre class="wp-block-preformatted">systemctl daemon-reload</pre>
<p>Next, start the VueJS service and enable it to start at system reboot with the following command:</p>
<pre class="wp-block-preformatted">systemctl start vuejs
systemctl enable vuejs</pre>
<p>You can verify the status of the VueJS service with the following command:</p>
<pre class="wp-block-preformatted">systemctl status vuejs</pre>
<p>You should get the following output:</p>
<pre class="wp-block-preformatted">● vuejs.service
Loaded: loaded (/lib/systemd/system/vuejs.service; static; vendor preset: enabled)
Active: active (running)
Main PID: 11730 (npm run serve -)
Tasks: 19 (limit: 2245)
Memory: 37.3M
CGroup: /system.slice/vuejs.service
├─11730 npm run serve --port=8080
├─11743 sh -c vue-cli-service serve &quot;--port=8080&quot;
└─11744 node /root/my-project/node_modules/.bin/vue-cli-service serve --port=8080</pre>
<h2>Step 6: Access VueJS Web UI</h2>
<p>Now, open your web browser and type:</p>
<pre class="wp-block-preformatted">http://your-server-ip-address:8080</pre>
<p>You should see your VueJS Application on the following screen:</p>
<div class="wp-block-image"><figure class="aligncenter size-large"><a href="https://www.linuxcloudvps.com/blog/wp-content/uploads/2022/05/install-vue-cli-on-ubuntu-20-04.jpg"><img loading="lazy" width="970" height="529" src="https://www.linuxcloudvps.com/blog/wp-content/uploads/2022/05/install-vue-cli-on-ubuntu-20-04-970x529.jpg" alt="" class="wp-image-1734" srcset="https://www.linuxcloudvps.com/blog/wp-content/uploads/2022/05/install-vue-cli-on-ubuntu-20-04-970x529.jpg 970w, https://www.linuxcloudvps.com/blog/wp-content/uploads/2022/05/install-vue-cli-on-ubuntu-20-04-470x256.jpg 470w, https://www.linuxcloudvps.com/blog/wp-content/uploads/2022/05/install-vue-cli-on-ubuntu-20-04-768x419.jpg 768w, https://www.linuxcloudvps.com/blog/wp-content/uploads/2022/05/install-vue-cli-on-ubuntu-20-04.jpg 1024w" sizes="(max-width: 970px) 100vw, 970px" /></a></figure></div>
<p>Congratulations! You have successfully installed the VueJS App using Vue CLI on your Ubuntu 20.04 server.</p>
<p>Of course, you don’t have to install Vue CLI on Ubuntu if you use one of <a href="https://www.rosehosting.com/managed-vps-hosting/">our Managed Hosting</a> services, in which case you can simply ask our expert Linux admins to install this for you. They are available 24×7 and will take care of your request immediately.</p>
<p><strong>PS</strong>. If you liked this post on how to install Vue CLI on Ubuntu, please share it with your friends on the social networks using the buttons on the left or simply leave a reply below. Thanks.</p>
<div class='heateor_sss_sharing_container heateor_sss_vertical_sharing heateor_sss_bottom_sharing' style='width:44px;left: -10px;top: 100px;-webkit-box-shadow:none;box-shadow:none;' data-heateor-sss-href='https://www.linuxcloudvps.com/blog/how-to-install-vue-cli-on-ubuntu-20-04/'><div class="heateor_sss_sharing_ul"><a class="heateor_sss_facebook" href="https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Fwww.linuxcloudvps.com%2Fblog%2Fhow-to-install-vue-cli-on-ubuntu-20-04%2F" title="Facebook" rel="nofollow noopener" target="_blank" style="font-size:32px!important;box-shadow:none;display:inline-block;vertical-align:middle"><span class="heateor_sss_svg" style="background-color:#3c589a;width:40px;height:40px;margin:0;display:inline-block;opacity:1;float:left;font-size:32px;box-shadow:none;display:inline-block;font-size:16px;padding:0 4px;vertical-align:middle;background-repeat:repeat;overflow:hidden;padding:0;cursor:pointer;box-sizing:content-box"><svg style="display:block;" focusable="false" aria-hidden="true" xmlns="http://www.w3.org/2000/svg" width="100%" height="100%" viewBox="-5 -5 42 42"><path d="M17.78 27.5V17.008h3.522l.527-4.09h-4.05v-2.61c0-1.182.33-1.99 2.023-1.99h2.166V4.66c-.375-.05-1.66-.16-3.155-.16-3.123 0-5.26 1.905-5.26 5.405v3.016h-3.53v4.09h3.53V27.5h4.223z" fill="#fff"></path></svg></span></a><a class="heateor_sss_button_twitter" href="https://twitter.com/intent/tweet?text=How%20to%20Install%20Vue%20CLI%20on%20Ubuntu%2020.04&url=https%3A%2F%2Fwww.linuxcloudvps.com%2Fblog%2Fhow-to-install-vue-cli-on-ubuntu-20-04%2F" title="Twitter" rel="nofollow noopener" target="_blank" style="font-size:32px!important;box-shadow:none;display:inline-block;vertical-align:middle"><span class="heateor_sss_svg heateor_sss_s__default heateor_sss_s_twitter" style="background-color:#55acee;width:40px;height:40px;margin:0;display:inline-block;opacity:1;float:left;font-size:32px;box-shadow:none;display:inline-block;font-size:16px;padding:0 4px;vertical-align:middle;background-repeat:repeat;overflow:hidden;padding:0;cursor:pointer;box-sizing:content-box"><svg style="display:block;" focusable="false" aria-hidden="true" xmlns="http://www.w3.org/2000/svg" width="100%" height="100%" viewBox="-4 -4 39 39"><path d="M28 8.557a9.913 9.913 0 0 1-2.828.775 4.93 4.93 0 0 0 2.166-2.725 9.738 9.738 0 0 1-3.13 1.194 4.92 4.92 0 0 0-3.593-1.55 4.924 4.924 0 0 0-4.794 6.049c-4.09-.21-7.72-2.17-10.15-5.15a4.942 4.942 0 0 0-.665 2.477c0 1.71.87 3.214 2.19 4.1a4.968 4.968 0 0 1-2.23-.616v.06c0 2.39 1.7 4.38 3.952 4.83-.414.115-.85.174-1.297.174-.318 0-.626-.03-.928-.086a4.935 4.935 0 0 0 4.6 3.42 9.893 9.893 0 0 1-6.114 2.107c-.398 0-.79-.023-1.175-.068a13.953 13.953 0 0 0 7.55 2.213c9.056 0 14.01-7.507 14.01-14.013 0-.213-.005-.426-.015-.637.96-.695 1.795-1.56 2.455-2.55z" fill="#fff"></path></svg></span></a><a class="heateor_sss_button_linkedin" href="https://www.linkedin.com/shareArticle?mini=true&url=https%3A%2F%2Fwww.linuxcloudvps.com%2Fblog%2Fhow-to-install-vue-cli-on-ubuntu-20-04%2F&title=How%20to%20Install%20Vue%20CLI%20on%20Ubuntu%2020.04" title="Linkedin" rel="nofollow noopener" target="_blank" style="font-size:32px!important;box-shadow:none;display:inline-block;vertical-align:middle"><span class="heateor_sss_svg heateor_sss_s__default heateor_sss_s_linkedin" style="background-color:#0077b5;width:40px;height:40px;margin:0;display:inline-block;opacity:1;float:left;font-size:32px;box-shadow:none;display:inline-block;font-size:16px;padding:0 4px;vertical-align:middle;background-repeat:repeat;overflow:hidden;padding:0;cursor:pointer;box-sizing:content-box"><svg style="display:block;" focusable="false" aria-hidden="true" xmlns="http://www.w3.org/2000/svg" width="100%" height="100%" viewBox="0 0 32 32"><path d="M6.227 12.61h4.19v13.48h-4.19V12.61zm2.095-6.7a2.43 2.43 0 0 1 0 4.86c-1.344 0-2.428-1.09-2.428-2.43s1.084-2.43 2.428-2.43m4.72 6.7h4.02v1.84h.058c.56-1.058 1.927-2.176 3.965-2.176 4.238 0 5.02 2.792 5.02 6.42v7.395h-4.183v-6.56c0-1.564-.03-3.574-2.178-3.574-2.18 0-2.514 1.7-2.514 3.46v6.668h-4.187V12.61z" fill="#fff"></path></svg></span></a><a class="heateor_sss_button_pinterest" onclick="javascript:void( (function() {var e=document.createElement('script' );e.setAttribute('type','text/javascript' );e.setAttribute('charset','UTF-8' );e.setAttribute('src','//assets.pinterest.com/js/pinmarklet.js?r='+Math.random()*99999999);document.body.appendChild(e)})());" title="Pinterest" rel="nofollow noopener" style="font-size:32px!important;box-shadow:none;display:inline-block;vertical-align:middle"><span class="heateor_sss_svg heateor_sss_s__default heateor_sss_s_pinterest" style="background-color:#cc2329;width:40px;height:40px;margin:0;display:inline-block;opacity:1;float:left;font-size:32px;box-shadow:none;display:inline-block;font-size:16px;padding:0 4px;vertical-align:middle;background-repeat:repeat;overflow:hidden;padding:0;cursor:pointer;box-sizing:content-box"><svg style="display:block;" focusable="false" aria-hidden="true" xmlns="http://www.w3.org/2000/svg" width="100%" height="100%" viewBox="-2 -2 35 35"><path fill="#fff" d="M16.539 4.5c-6.277 0-9.442 4.5-9.442 8.253 0 2.272.86 4.293 2.705 5.046.303.125.574.005.662-.33.061-.231.205-.816.27-1.06.088-.331.053-.447-.191-.736-.532-.627-.873-1.439-.873-2.591 0-3.338 2.498-6.327 6.505-6.327 3.548 0 5.497 2.168 5.497 5.062 0 3.81-1.686 7.025-4.188 7.025-1.382 0-2.416-1.142-2.085-2.545.397-1.674 1.166-3.48 1.166-4.689 0-1.081-.581-1.983-1.782-1.983-1.413 0-2.548 1.462-2.548 3.419 0 1.247.421 2.091.421 2.091l-1.699 7.199c-.505 2.137-.076 4.755-.039 5.019.021.158.223.196.314.077.13-.17 1.813-2.247 2.384-4.324.162-.587.929-3.631.929-3.631.46.876 1.801 1.646 3.227 1.646 4.247 0 7.128-3.871 7.128-9.053.003-3.918-3.317-7.568-8.361-7.568z" /></svg></span></a><a class="heateor_sss_button_reddit" href="https://reddit.com/submit?url=https%3A%2F%2Fwww.linuxcloudvps.com%2Fblog%2Fhow-to-install-vue-cli-on-ubuntu-20-04%2F&title=How%20to%20Install%20Vue%20CLI%20on%20Ubuntu%2020.04" title="Reddit" rel="nofollow noopener" target="_blank" style="font-size:32px!important;box-shadow:none;display:inline-block;vertical-align:middle"><span class="heateor_sss_svg heateor_sss_s__default heateor_sss_s_reddit" style="background-color:#ff5700;width:40px;height:40px;margin:0;display:inline-block;opacity:1;float:left;font-size:32px;box-shadow:none;display:inline-block;font-size:16px;padding:0 4px;vertical-align:middle;background-repeat:repeat;overflow:hidden;padding:0;cursor:pointer;box-sizing:content-box"><svg style="display:block;" focusable="false" aria-hidden="true" xmlns="http://www.w3.org/2000/svg" width="100%" height="100%" viewBox="-3.5 -3.5 39 39"><path d="M28.543 15.774a2.953 2.953 0 0 0-2.951-2.949 2.882 2.882 0 0 0-1.9.713 14.075 14.075 0 0 0-6.85-2.044l1.38-4.349 3.768.884a2.452 2.452 0 1 0 .24-1.176l-4.274-1a.6.6 0 0 0-.709.4l-1.659 5.224a14.314 14.314 0 0 0-7.316 2.029 2.908 2.908 0 0 0-1.872-.681 2.942 2.942 0 0 0-1.618 5.4 5.109 5.109 0 0 0-.062.765c0 4.158 5.037 7.541 11.229 7.541s11.22-3.383 11.22-7.541a5.2 5.2 0 0 0-.053-.706 2.963 2.963 0 0 0 1.427-2.51zm-18.008 1.88a1.753 1.753 0 0 1 1.73-1.74 1.73 1.73 0 0 1 1.709 1.74 1.709 1.709 0 0 1-1.709 1.711 1.733 1.733 0 0 1-1.73-1.711zm9.565 4.968a5.573 5.573 0 0 1-4.081 1.272h-.032a5.576 5.576 0 0 1-4.087-1.272.6.6 0 0 1 .844-.854 4.5 4.5 0 0 0 3.238.927h.032a4.5 4.5 0 0 0 3.237-.927.6.6 0 1 1 .844.854zm-.331-3.256a1.726 1.726 0 1 1 1.709-1.712 1.717 1.717 0 0 1-1.712 1.712z" fill="#fff" /></svg></span></a><a class="heateor_sss_more" title="More" rel="nofollow noopener" style="font-size: 32px!important;border:0;box-shadow:none;display:inline-block!important;font-size:16px;padding:0 4px;vertical-align: middle;display:inline;" href="https://www.linuxcloudvps.com/blog/how-to-install-vue-cli-on-ubuntu-20-04/" onclick="event.preventDefault()"><span class="heateor_sss_svg" style="background-color:#ee8e2d;width:40px;height:40px;margin:0;display:inline-block!important;opacity:1;float:left;font-size:32px!important;box-shadow:none;display:inline-block;font-size:16px;padding:0 4px;vertical-align:middle;display:inline;background-repeat:repeat;overflow:hidden;padding:0;cursor:pointer;box-sizing:content-box;" onclick="heateorSssMoreSharingPopup(this, 'https://www.linuxcloudvps.com/blog/how-to-install-vue-cli-on-ubuntu-20-04/', 'How%20to%20Install%20Vue%20CLI%20on%20Ubuntu%2020.04', '' )"><svg xmlns="http://www.w3.org/2000/svg" style="display:block;" width="100%" height="100%" viewBox="-4 -4 38 38"><circle cx="10" cy="15" r="3" fill="#fff"></circle><circle cx="20" cy="10" r="3" fill="#fff"></circle><circle cx="20" cy="20" r="3" fill="#fff"></circle><path d="M 10 15 L 20 10 m 0 10 L 10 15" class="heateor_sss_svg_stroke heateor_sss_no_fill" stroke-width="2" stroke="#fff"></path></svg></span></a></div><div class="heateorSssClear"></div></div> </section>
</article>
<p class='alert alert-info'>Be the first to write a comment.</p>
<section id="respond">
<h3>Your feedback</h3>
<p><a rel="nofollow" id="cancel-comment-reply-link" href="/blog/how-to-install-vue-cli-on-ubuntu-20-04/#respond" style="display:none;">Click here to cancel reply.</a></p>
<form action="https://www.linuxcloudvps.com/blog/wp-comments-post.php" method="post" id="commentform">
<div class="form-group">
<label for="author">Your name <span class="text-muted">(required)</span></label>
<input type="text" class="form-control" name="author" id="author" placeholder="Your name" value="" aria-required="true">
</div>
<div class="form-group">
<label for="email">Your email address(required, but will not be published) <span class="text-muted"></span></label>
<input type="email" class="form-control" name="email" id="email" placeholder="Your email address" value="" aria-required="true">
</div>
<div class="form-group">
<label for="comment">Your comment</label>
<textarea autocomplete="new-password" id="a3e83ee047" name="a3e83ee047" class="form-control" placeholder="Your comment" rows="8" aria-required="true"></textarea><textarea id="comment" aria-label="hp-comment" aria-hidden="true" name="comment" autocomplete="new-password" style="padding:0 !important;clip:rect(1px, 1px, 1px, 1px) !important;position:absolute !important;white-space:nowrap !important;height:1px !important;width:1px !important;overflow:hidden !important;" tabindex="-1"></textarea><script data-cfasync="false" src="/cdn-cgi/scripts/5c5dd728/cloudflare-static/email-decode.min.js"></script><script data-noptimize type="text/javascript">document.getElementById("comment").setAttribute( "id", "a53db6235dd463eac8e3fddbf8ae74ef" );document.getElementById("a3e83ee047").setAttribute( "id", "comment" );</script>
</div>
<p><input name="submit" class="btn btn-default" type="submit" id="submit" value="Submit comment"></p>
<input type='hidden' name='comment_post_ID' value='1733' id='comment_post_ID' />
<input type='hidden' name='comment_parent' id='comment_parent' value='0' />
<div class="g-recaptcha" data-sitekey="6LeLc1sUAAAAAFjBEqiVoKnjFxmBTJYJbuoljkuY" data-theme="standard"></div><script type="text/javascript" src="https://www.google.com/recaptcha/api.js?hl=en"></script> <div id="recaptcha-submit-btn-area">&nbsp;</div>
<noscript>
            <style type='text/css'>#submit {display:none;}</style>
            <input name="submit" type="submit" id="submit-alt" tabindex="6"
                value="Submit Comment"/> 
            </noscript> </form>
</section>
</div>
</div>
<div class="col-xs-6 col-sm-4" id="sidebar" role="navigation">
<aside class="sidebar">
<section class="search-2 widget_search"><form class="form-inline" role="search" method="get" id="searchform" action="https://www.linuxcloudvps.com/blog/">
<input class="form-control" type="text" value="" placeholder="Search..." name="s" id="s" />
<button type="submit" id="searchsubmit" value="Search" class="btn btn-default"><i class="glyphicon glyphicon-search"></i></button>
</form></section>
<section class="recent-posts-2 widget_recent_entries">
<h4>Recent Posts</h4>
<ul>
<li>
<a href="https://www.linuxcloudvps.com/blog/how-to-install-vue-cli-on-ubuntu-20-04/" aria-current="page">How to Install Vue CLI on Ubuntu 20.04</a>
</li>
<li>
<a href="https://www.linuxcloudvps.com/blog/how-to-install-code-server-ide-platform-on-ubuntu-20-04/">How to Install Code-Server IDE platform on Ubuntu 20.04</a>
</li>
<li>
<a href="https://www.linuxcloudvps.com/blog/how-to-install-and-use-php-composer-on-ubuntu-20-04/">How to Install and Use PHP Composer on Ubuntu 20.04</a>
</li>
<li>
<a href="https://www.linuxcloudvps.com/blog/how-to-install-openmrs-on-ubuntu-20-04/">How to Install OpenMRS on Ubuntu 20.04</a>
</li>
<li>
<a href="https://www.linuxcloudvps.com/blog/how-to-install-cachet-status-page-system-on-ubuntu-20-04/">How to Install Cachet Status Page System on Ubuntu 20.04</a>
</li>
</ul>
</section><section class="categories-2 widget_categories"><h4>Categories</h4>
<ul>
<li class="cat-item cat-item-207"><a href="https://www.linuxcloudvps.com/blog/category/guide/">Guide</a>
</li>
<li class="cat-item cat-item-206"><a href="https://www.linuxcloudvps.com/blog/category/how-to/">How To</a>
</li>
<li class="cat-item cat-item-3"><a href="https://www.linuxcloudvps.com/blog/category/linuxcloudvps/">linuxcloudvps</a>
</li>
<li class="cat-item cat-item-204"><a href="https://www.linuxcloudvps.com/blog/category/openssh/">OpenSSH</a>
</li>
<li class="cat-item cat-item-11"><a href="https://www.linuxcloudvps.com/blog/category/scripts/">Scripts</a>
</li>
<li class="cat-item cat-item-12"><a href="https://www.linuxcloudvps.com/blog/category/tips-and-tricks/">Tips and Tricks</a>
</li>
<li class="cat-item cat-item-13"><a href="https://www.linuxcloudvps.com/blog/category/tutorials/">Tutorials</a>
</li>
<li class="cat-item cat-item-208"><a href="https://www.linuxcloudvps.com/blog/category/ubuntu/">Ubuntu</a>
</li>
<li class="cat-item cat-item-212"><a href="https://www.linuxcloudvps.com/blog/category/ubuntu-18-04/">Ubuntu 18.04</a>
</li>
<li class="cat-item cat-item-205"><a href="https://www.linuxcloudvps.com/blog/category/ubuntu-20-04/">Ubuntu 20.04</a>
</li>
<li class="cat-item cat-item-1"><a href="https://www.linuxcloudvps.com/blog/category/uncategorized/">Uncategorized</a>
</li>
</ul>
</section></aside> </div>
</div>
</div>
<section class="promo">
<div class="container">
<div class="row text-center">
<h2>Sign up for a LinuxCloudVPS today</h2>
<a class="btn btn-primary btn-lg" href="https://www.linuxcloudvps.com/cloud-vps.html">Get Started Now</a>
</div>
</div>
</section>
</main>
<footer class="main-footer">
<div class="container">
<div class="row">
<div class="col-sm-2 menu">
<h3>Company</h3>
<ul>
<li>
<a href="https://www.linuxcloudvps.com/aboutus.html">About us</a>
</li>
<li>
<a href="https://www.linuxcloudvps.com/contact.html">Contact us</a>
</li>
<li>
<a href="/">Blog</a>
</li>
<li>
<a href="https://www.linuxcloudvps.com/clientportal/index.php?/tickets/">Support</a>
</li>
<li>
<a href="https://www.linuxcloudvps.com/speed-test.html">Speed Test</a>
</li>
</ul>
</div>
<div class="col-sm-3 menu">
<h3>Hosting Solutions</h3>
<ul>
<li>
<a href="https://www.linuxcloudvps.com/cloud-vps.html">Cloud VPS</a>
</li>
<li>
<li><a href="https://linuxcloudvps.com/clientportal/index.php?/affiliates/">Affiliate Program</a></li>
</li>
</ul>
</div>
<div class="col-sm-3 menu">
<h3>Linux Cloud Hosting</h3>
<ul>
<li>
<a href="https://www.linuxcloudvps.com/centos-cloud-vps.html">CentOS Cloud Server</a>
</li>
<li>
<a href="https://www.linuxcloudvps.com/ubuntu-cloud-vps.html">Ubuntu Cloud Server</a>
</li>
<li>
<a href="https://www.linuxcloudvps.com/debian-cloud-vps.html">Debian Cloud Server</a>
</li>
<li>
<a href="https://www.linuxcloudvps.com/arch-linux-cloud-vps.html">Arch-Linux Cloud Server</a>
</li>
<li>
<a href="https://www.linuxcloudvps.com/elastix-cloud-vps.html">Elastix Cloud VPS</a>
</li>
<li>
<a href="https://www.linuxcloudvps.com/opensuse-cloud-vps.html">OpenSUSE Cloud Server</a>
</li>
<li>
<a href="https://www.linuxcloudvps.com/scientific-linux-cloud-vps.html">Scientific Linux Cloud Server</a>
</li>
</ul>
</div>
<div class="col-sm-2 menu">
<h3>Other Services</h3>
<ul class="">
<li><a href="https://www.linuxcloudvps.com/clientportal/index.php/checkdomain/domain-registration#register">Domain Registration</a></li>
<li><a href="https://www.linuxcloudvps.com/clientportal/index.php/checkdomain/domain-registration#transfer">Domain Transfer</a></li>
<li><a href="https://www.linuxcloudvps.com/ssl-certificates.html">SSL Certificates</a></li>
</ul>
</div>
<div class="col-sm-2 menu">
<h3>Connect</h3>
<ul class="">
<li>
<a target="_blank" href="https://www.facebook.com/LinuxCloudVPS">Facebook</a>
</li>
<li>
<a target="_blank" href="https://twitter.com/LinuxCloudVPS">Twitter</a>
</li>
<li>
<a target="_blank" href="https://www.linkedin.com/company/linuxcloudvps-com">Linkedin</a>
</li>
</ul>
</div>
</div>
<div class="row credits">
<div class="col-md-6">
<p class="pull-left"><a href="https://www.linuxcloudvps.com/tos.html">Terms of Service</a> and <a href="https://www.linuxcloudvps.com/policies.html">other policies</a></p>
</div>
<div class="col-md-6">
<p class="pull-right">&copy; 2010-2017 Rose Web Services LLC</p>
</div>
</div>
</div>
</footer>

<script type="text/javascript">
            var sub = document.getElementById('submit');
            document.getElementById('recaptcha-submit-btn-area').appendChild (sub);
            document.getElementById('submit').tabIndex = 6;
            if ( typeof _recaptcha_wordpress_savedcomment != 'undefined') {
                document.getElementById('comment').value = 
                    _recaptcha_wordpress_savedcomment;
            }
            </script><script type='text/javascript' id='heateor_sss_sharing_js-js-before'>
function heateorSssLoadEvent(e) {var t=window.onload;if (typeof window.onload!="function") {window.onload=e}else{window.onload=function() {t();e()}}};	var heateorSssSharingAjaxUrl = 'https://www.linuxcloudvps.com/blog/wp-admin/admin-ajax.php', heateorSssCloseIconPath = 'https://www.linuxcloudvps.com/blog/wp-content/plugins/sassy-social-share/public/../images/close.png', heateorSssPluginIconPath = 'https://www.linuxcloudvps.com/blog/wp-content/plugins/sassy-social-share/public/../images/logo.png', heateorSssHorizontalSharingCountEnable = 0, heateorSssVerticalSharingCountEnable = 0, heateorSssSharingOffset = -10; var heateorSssMobileStickySharingEnabled = 1;var heateorSssCopyLinkMessage = "Link copied.";var heateorSssUrlCountFetched = [], heateorSssSharesText = 'Shares', heateorSssShareText = 'Share';function heateorSssPopup(e) {window.open(e,"popUpWindow","height=400,width=600,left=400,top=100,resizable,scrollbars,toolbar=0,personalbar=0,menubar=no,location=no,directories=no,status")}
</script>
<script type='text/javascript' src='https://www.linuxcloudvps.com/blog/wp-content/plugins/sassy-social-share/public/js/sassy-social-share-public.js?ver=3.3.42' id='heateor_sss_sharing_js-js'></script>
<script type='text/javascript' src='https://www.linuxcloudvps.com/blog/wp-content/themes/lcvps2015/js/bootstrap.min.js' id='bootstrap-js-js'></script>
<script type='text/javascript' src='https://www.linuxcloudvps.com/blog/wp-content/themes/lcvps2015/js/lcvps.js' id='wbst-js-js'></script>
<script type='text/javascript' src='https://www.linuxcloudvps.com/blog/wp-includes/js/comment-reply.min.js?ver=5.9.3' id='comment-reply-js'></script>
</body>
</html>
