<!DOCTYPE html>
<html>
<head>
<meta charset="utf-8">
<meta http-equiv="X-UA-Compatible" content="IE=edge">
<meta property="fb:pages" content="206873672715222" />
<meta name="viewport" content="width=device-width, initial-scale=1.0">
<link href='https://fonts.googleapis.com/css?family=Montserrat:400,700|Open+Sans:400,300,600,400italic,700' rel='stylesheet' type='text/css'>
<script>(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src='https://www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);})(window,document,'script','dataLayer','GTM-MSX4CLH');</script>
<style type="text/css">
					.heateor_sss_button_instagram span.heateor_sss_svg,a.heateor_sss_instagram span.heateor_sss_svg{background:radial-gradient(circle at 30% 107%,#fdf497 0,#fdf497 5%,#fd5949 45%,#d6249f 60%,#285aeb 90%)}
											.heateor_sss_horizontal_sharing .heateor_sss_svg,.heateor_sss_standard_follow_icons_container .heateor_sss_svg{
							color: #fff;
						border-width: 0px;
			border-style: solid;
			border-color: transparent;
		}
					.heateor_sss_horizontal_sharing .heateorSssTCBackground{
				color:#666;
			}
					.heateor_sss_horizontal_sharing span.heateor_sss_svg:hover,.heateor_sss_standard_follow_icons_container span.heateor_sss_svg:hover{
						border-color: transparent;
		}
		.heateor_sss_vertical_sharing span.heateor_sss_svg,.heateor_sss_floating_follow_icons_container span.heateor_sss_svg{
							color: #fff;
						border-width: 0px;
			border-style: solid;
			border-color: transparent;
		}
				.heateor_sss_vertical_sharing .heateorSssTCBackground{
			color:#666;
		}
						.heateor_sss_vertical_sharing span.heateor_sss_svg:hover,.heateor_sss_floating_follow_icons_container span.heateor_sss_svg:hover{
						border-color: transparent;
		}
		@media screen and (max-width:783px) {.heateor_sss_vertical_sharing{display:none!important}}div.heateor_sss_mobile_footer{display:none;}@media screen and (max-width:783px){div.heateor_sss_bottom_sharing .heateorSssTCBackground{background-color:white}div.heateor_sss_bottom_sharing{width:100%!important;left:0!important;}div.heateor_sss_bottom_sharing a{width:16.666666666667% !important;}div.heateor_sss_bottom_sharing .heateor_sss_svg{width: 100% !important;}div.heateor_sss_bottom_sharing div.heateorSssTotalShareCount{font-size:1em!important;line-height:28px!important}div.heateor_sss_bottom_sharing div.heateorSssTotalShareText{font-size:.7em!important;line-height:0px!important}div.heateor_sss_mobile_footer{display:block;height:40px;}.heateor_sss_bottom_sharing{padding:0!important;display:block!important;width:auto!important;bottom:-2px!important;top: auto!important;}.heateor_sss_bottom_sharing .heateor_sss_square_count{line-height:inherit;}.heateor_sss_bottom_sharing .heateorSssSharingArrow{display:none;}.heateor_sss_bottom_sharing .heateorSssTCBackground{margin-right:1.1em!important}}		</style>

<title>10 Useful firewall-cmd Commands in Linux | LinuxCloudVPS Blog</title>
<meta name="description" content="In this blog post, we are going to explain 10 useful firewall-cmd commands in Linux with real examples.Let&#039;s get started!" />
<meta name="robots" content="max-image-preview:large" />
<link rel="canonical" href="https://www.linuxcloudvps.com/blog/10-useful-firewall-cmd-commands-in-linux/" />
<meta name="generator" content="All in One SEO (AIOSEO) 4.2.3.1 " />
<meta property="og:locale" content="en_US" />
<meta property="og:site_name" content="LinuxCloudVPS Blog |" />
<meta property="og:type" content="article" />
<meta property="og:title" content="10 Useful firewall-cmd Commands in Linux | LinuxCloudVPS Blog" />
<meta property="og:description" content="In this blog post, we are going to explain 10 useful firewall-cmd commands in Linux with real examples.Let&#039;s get started!" />
<meta property="og:url" content="https://www.linuxcloudvps.com/blog/10-useful-firewall-cmd-commands-in-linux/" />
<meta property="article:published_time" content="2022-07-30T17:30:00+00:00" />
<meta property="article:modified_time" content="2022-07-29T15:33:54+00:00" />
<meta name="twitter:card" content="summary" />
<meta name="twitter:title" content="10 Useful firewall-cmd Commands in Linux | LinuxCloudVPS Blog" />
<meta name="twitter:description" content="In this blog post, we are going to explain 10 useful firewall-cmd commands in Linux with real examples.Let&#039;s get started!" />
<script type="application/ld+json" class="aioseo-schema">
			{"@context":"https:\/\/schema.org","@graph":[{"@type":"WebSite","@id":"https:\/\/www.linuxcloudvps.com\/blog\/#website","url":"https:\/\/www.linuxcloudvps.com\/blog\/","name":"LinuxCloudVPS Blog","inLanguage":"en-US","publisher":{"@id":"https:\/\/www.linuxcloudvps.com\/blog\/#organization"}},{"@type":"Organization","@id":"https:\/\/www.linuxcloudvps.com\/blog\/#organization","name":"LinuxCloudVPS Blog","url":"https:\/\/www.linuxcloudvps.com\/blog\/"},{"@type":"BreadcrumbList","@id":"https:\/\/www.linuxcloudvps.com\/blog\/10-useful-firewall-cmd-commands-in-linux\/#breadcrumblist","itemListElement":[{"@type":"ListItem","@id":"https:\/\/www.linuxcloudvps.com\/blog\/#listItem","position":1,"item":{"@type":"WebPage","@id":"https:\/\/www.linuxcloudvps.com\/blog\/","name":"Home","description":"LinuxCloudVPS.com Blog. Information, tips and tricks, tutorials and more for our Linux Cloud VPS Hosting","url":"https:\/\/www.linuxcloudvps.com\/blog\/"},"nextItem":"https:\/\/www.linuxcloudvps.com\/blog\/10-useful-firewall-cmd-commands-in-linux\/#listItem"},{"@type":"ListItem","@id":"https:\/\/www.linuxcloudvps.com\/blog\/10-useful-firewall-cmd-commands-in-linux\/#listItem","position":2,"item":{"@type":"WebPage","@id":"https:\/\/www.linuxcloudvps.com\/blog\/10-useful-firewall-cmd-commands-in-linux\/","name":"10 Useful firewall-cmd Commands in Linux","description":"In this blog post, we are going to explain 10 useful firewall-cmd commands in Linux with real examples.Let's get started!","url":"https:\/\/www.linuxcloudvps.com\/blog\/10-useful-firewall-cmd-commands-in-linux\/"},"previousItem":"https:\/\/www.linuxcloudvps.com\/blog\/#listItem"}]},{"@type":"Person","@id":"https:\/\/www.linuxcloudvps.com\/blog\/author\/r0s3admin\/#author","url":"https:\/\/www.linuxcloudvps.com\/blog\/author\/r0s3admin\/","name":"admin"},{"@type":"WebPage","@id":"https:\/\/www.linuxcloudvps.com\/blog\/10-useful-firewall-cmd-commands-in-linux\/#webpage","url":"https:\/\/www.linuxcloudvps.com\/blog\/10-useful-firewall-cmd-commands-in-linux\/","name":"10 Useful firewall-cmd Commands in Linux | LinuxCloudVPS Blog","description":"In this blog post, we are going to explain 10 useful firewall-cmd commands in Linux with real examples.Let's get started!","inLanguage":"en-US","isPartOf":{"@id":"https:\/\/www.linuxcloudvps.com\/blog\/#website"},"breadcrumb":{"@id":"https:\/\/www.linuxcloudvps.com\/blog\/10-useful-firewall-cmd-commands-in-linux\/#breadcrumblist"},"author":"https:\/\/www.linuxcloudvps.com\/blog\/author\/r0s3admin\/#author","creator":"https:\/\/www.linuxcloudvps.com\/blog\/author\/r0s3admin\/#author","image":{"@type":"ImageObject","@id":"https:\/\/www.linuxcloudvps.com\/blog\/#mainImage","url":"https:\/\/www.linuxcloudvps.com\/blog\/wp-content\/uploads\/2022\/07\/10-useful-firewall-cmd-commands-in-linux.webp","width":742,"height":372,"caption":"10 useful firewall cmd commands in linux"},"primaryImageOfPage":{"@id":"https:\/\/www.linuxcloudvps.com\/blog\/10-useful-firewall-cmd-commands-in-linux\/#mainImage"},"datePublished":"2022-07-30T17:30:00-05:00","dateModified":"2022-07-29T15:33:54-05:00"},{"@type":"Article","@id":"https:\/\/www.linuxcloudvps.com\/blog\/10-useful-firewall-cmd-commands-in-linux\/#article","name":"10 Useful firewall-cmd Commands in Linux | LinuxCloudVPS Blog","description":"In this blog post, we are going to explain 10 useful firewall-cmd commands in Linux with real examples.Let's get started!","inLanguage":"en-US","headline":"10 Useful firewall-cmd Commands in Linux","author":{"@id":"https:\/\/www.linuxcloudvps.com\/blog\/author\/r0s3admin\/#author"},"publisher":{"@id":"https:\/\/www.linuxcloudvps.com\/blog\/#organization"},"datePublished":"2022-07-30T17:30:00-05:00","dateModified":"2022-07-29T15:33:54-05:00","commentCount":2,"articleSection":"Uncategorized, cmd, commands, firewall, linux","mainEntityOfPage":{"@id":"https:\/\/www.linuxcloudvps.com\/blog\/10-useful-firewall-cmd-commands-in-linux\/#webpage"},"isPartOf":{"@id":"https:\/\/www.linuxcloudvps.com\/blog\/10-useful-firewall-cmd-commands-in-linux\/#webpage"},"image":{"@type":"ImageObject","@id":"https:\/\/www.linuxcloudvps.com\/blog\/#articleImage","url":"https:\/\/www.linuxcloudvps.com\/blog\/wp-content\/uploads\/2022\/07\/10-useful-firewall-cmd-commands-in-linux.webp","width":742,"height":372,"caption":"10 useful firewall cmd commands in linux"}}]}
		</script>

<link rel="amphtml" href="https://www.linuxcloudvps.com/blog/10-useful-firewall-cmd-commands-in-linux/amp/" /><meta name="generator" content="AMP for WP 1.0.77.47" /><link rel='dns-prefetch' href='//s.w.org' />
<script type="text/javascript">
window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/14.0.0\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/14.0.0\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/www.linuxcloudvps.com\/blog\/wp-includes\/js\/wp-emoji-release.min.js?ver=6.0.1"}};
/*! This file is auto-generated */
!function(e,a,t){var n,r,o,i=a.createElement("canvas"),p=i.getContext&&i.getContext("2d");function s(e,t){var a=String.fromCharCode,e=(p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,e),0,0),i.toDataURL());return p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,t),0,0),e===i.toDataURL()}function c(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(o=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},r=0;r<o.length;r++)t.supports[o[r]]=function(e){if(!p||!p.fillText)return!1;switch(p.textBaseline="top",p.font="600 32px Arial",e){case"flag":return s([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])?!1:!s([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!s([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]);case"emoji":return!s([129777,127995,8205,129778,127999],[129777,127995,8203,129778,127999])}return!1}(o[r]),t.supports.everything=t.supports.everything&&t.supports[o[r]],"flag"!==o[r]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[o[r]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(e=t.source||{}).concatemoji?c(e.concatemoji):e.wpemoji&&e.twemoji&&(c(e.twemoji),c(e.wpemoji)))}(window,document,window._wpemojiSettings);
</script>
<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 0.07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='wp-block-library-css' href='https://www.linuxcloudvps.com/blog/wp-includes/css/dist/block-library/style.min.css?ver=6.0.1' type='text/css' media='all' />
<style id='global-styles-inline-css' type='text/css'>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</style>
<link rel='stylesheet' id='heateor_sss_frontend_css-css' href='https://www.linuxcloudvps.com/blog/wp-content/plugins/sassy-social-share/public/css/sassy-social-share-public.css?ver=3.3.42' type='text/css' media='all' />
<link rel='stylesheet' id='wbst-css-css' href='https://www.linuxcloudvps.com/blog/wp-content/themes/lcvps2015/css/lcvps.css' type='text/css' media='all' />
<link rel='stylesheet' id='site-css-css' href='https://www.linuxcloudvps.com/assets/css/style.css' type='text/css' media='all' />
<link rel='stylesheet' id='core3.0-css' href='https://www.linuxcloudvps.com/blog/wp-content/plugins/wp-syntaxhighlighter/syntaxhighlighter3/styles/shCore.css?ver=3.0' type='text/css' media='all' />
<link rel='stylesheet' id='core-Default3.0-css' href='https://www.linuxcloudvps.com/blog/wp-content/plugins/wp-syntaxhighlighter/syntaxhighlighter3/styles/shCoreDefault.css?ver=3.0' type='text/css' media='all' />
<link rel='stylesheet' id='theme-Default3.0-css' href='https://www.linuxcloudvps.com/blog/wp-content/plugins/wp-syntaxhighlighter/syntaxhighlighter3/styles/shThemeDefault.css?ver=3.0' type='text/css' media='all' />
<script type='text/javascript' src='https://www.linuxcloudvps.com/blog/wp-includes/js/jquery/jquery.min.js?ver=3.6.0' id='jquery-core-js'></script>
<script type='text/javascript' src='https://www.linuxcloudvps.com/blog/wp-includes/js/jquery/jquery-migrate.min.js?ver=3.3.2' id='jquery-migrate-js'></script>
<script type='text/javascript' src='https://www.linuxcloudvps.com/blog/wp-content/themes/lcvps2015/js/modernizr-2.6.2.min.js' id='modernizr-js'></script>
<link rel="https://api.w.org/" href="https://www.linuxcloudvps.com/blog/wp-json/" /><link rel="alternate" type="application/json" href="https://www.linuxcloudvps.com/blog/wp-json/wp/v2/posts/1740" /><link rel="alternate" type="application/json+oembed" href="https://www.linuxcloudvps.com/blog/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.linuxcloudvps.com%2Fblog%2F10-useful-firewall-cmd-commands-in-linux%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://www.linuxcloudvps.com/blog/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.linuxcloudvps.com%2Fblog%2F10-useful-firewall-cmd-commands-in-linux%2F&#038;format=xml" />
<link rel="author" href="https://plus.google.com/109398602334617462972" />

<style type='text/css'>
.syntaxhighlighter,
.syntaxhighlighter a,
.syntaxhighlighter div,
.syntaxhighlighter code,
.syntaxhighlighter table,
.syntaxhighlighter table td,
.syntaxhighlighter table tr,
.syntaxhighlighter table tbody,
.syntaxhighlighter table thead,
.syntaxhighlighter table caption,
.syntaxhighlighter textarea {
font-size: 12px !important; /* Set the font size in pixels */  
font-family: "Consolas", "Bitstream Vera Sans Mono", "Courier New", Courier, monospace !important; /* Set the font type */  
}
.syntaxhighlighter table caption {
/* For Title(Caption) */  
font-size: 14px !important; /* Set the font size in pixels */  
font-family: "Consolas", "Bitstream Vera Sans Mono", "Courier New", Courier, monospace !important; /* Set the font type */  
}
.syntaxhighlighter.nogutter td.code .line {
/* Set the left padding space when no-gutter in ver. 3.0 */  
padding-left: 3px !important;
}
.syntaxhighlighter {
/* For Chrome/Safari(WebKit) */  
/* Hide the superfluous vertical scrollbar in ver. 3.0 */  
overflow-y: hidden !important;
padding: 1px !important;
}
.widget-area.syntaxhighlighter a,
.widget-area.syntaxhighlighter div,
.widget-area.syntaxhighlighter code,
.widget-area.syntaxhighlighter table,
.widget-area.syntaxhighlighter table td,
.widget-area.syntaxhighlighter table tr,
.widget-area.syntaxhighlighter table tbody,
.widget-area.syntaxhighlighter table thead,
.widget-area.syntaxhighlighter table caption,
.widget-area.syntaxhighlighter textarea {
/* For Widget */  
font-size: 14px !important; /* Set the font size in pixels */  
font-family: "Consolas", "Bitstream Vera Sans Mono", "Courier New", Courier, monospace !important; /* Set the font type */  
}
.widget-area table caption {
/* For Widget */  
/* For Title(Caption) */  
font-size: 10px !important; /* Set the font size in pixels */  
font-family: "Consolas", "Bitstream Vera Sans Mono", "Courier New", Courier, monospace !important; /* Set the font type */  
}

.syntaxhighlighter .toolbar {
  display: none !important;
}
</style>

<style type="text/css" id="wp-custom-css">
			/*
You can add your own CSS here.

Click the help icon above to learn more.
*/

section h2 {
font-size: 22px;
}
section h3 {
font-size: 19px;
}
		</style>
</head>
<body class="post-template-default single single-post postid-1740 single-format-standard unknown">
<header>
<nav class="navbar navbar-default navbar-fixed-top" role="navigation">
<div class="container">
<div class="navbar-header">
<a href="https://www.linuxcloudvps.com/index.html" class="navbar-brand"><img alt="LinuxCloudVPS" src="https://www.linuxcloudvps.com/assets/images/logo.png"></a>
<button data-target="#navbar-main" data-toggle="collapse" type="button" class="navbar-toggle">
<span class="icon-bar"></span>
<span class="icon-bar"></span>
<span class="icon-bar"></span>
</button>
</div>
<div id="navbar-main" class="navbar-collapse collapse">
<ul class="nav navbar-nav navbar-right">
<li><a href="https://www.linuxcloudvps.com/aboutus.html">Company</a></li>
<li class="dropdown"><a href="https://www.linuxcloudvps.com/cloud-hosting.html" data-toggle="dropdown" class="dropdown-toggle">Hosting<span class="caret"></span></a>
<ul class="dropdown-menu">
<li><a href="https://www.linuxcloudvps.com/cloud-vps.html">Cloud VPS</a></li>
<li><a href="https://www.linuxcloudvps.com/clientportal/index.php?/affiliates/">Affiliate Program</a></li>
</ul>
</li>
<li class="dropdown"><a href="#" data-toggle="dropdown" class="dropdown-toggle">Domains <span class="caret"></span></a>
<ul class="dropdown-menu">
<li><a href="https://www.linuxcloudvps.com/clientportal/index.php/checkdomain/domain-registration#register">Register New</a></li>
<li><a href="https://www.linuxcloudvps.com/clientportal/index.php/checkdomain/domain-registration#transfer">Transfer Domains</a></li>
</ul>
</li>
<li class="dropdown"><a href="#" data-toggle="dropdown" class="dropdown-toggle">SSL Certs <span class="caret"></span></a>
<ul class="dropdown-menu">
<li class="dropdown-header"><span></span>By brand</li>
<li><a href="https://www.linuxcloudvps.com/ssl-certificates.html">GeoTrust</a></li>
<li><a href="https://www.linuxcloudvps.com/ssl-certificates.html#comodo">Comodo</a></li>
<li><a href="https://www.linuxcloudvps.com/ssl-certificates.html#rapidssl">RapidSSL</a></li>
<li><a href="https://www.linuxcloudvps.com/ssl-certificates.html#symantec">Symantec</a></li>
<li><a href="https://www.linuxcloudvps.com/ssl-certificates.html#thawte">Thawte</a></li>
<li class="dropdown-header">By Type</li>
<li><a href="https://www.linuxcloudvps.com/ssl-certificates-by-type.html">Domain Validation</a></li>
<li><a href="https://www.linuxcloudvps.com/ssl-certificates-by-type.html#organization">Organization Validation</a></li>
<li><a href="https://www.linuxcloudvps.com/ssl-certificates-by-type.html#extended">Extended Validation</a></li>
<li><a href="https://www.linuxcloudvps.com/ssl-certificates-by-type.html#wildcard">Wildcard SSL</a></li>
<li><a href="https://www.linuxcloudvps.com/ssl-certificates-by-type.html#codesigning">Code Signing SSL</a></li>
<li><a href="https://www.linuxcloudvps.com/ssl-certificates-by-type.html#sgs">SCG SSL</a></li>
</ul>
</li>
<li class="hidden-sm dropdown"><a href="#" data-toggle="dropdown" class="dropdown-toggle">Support<span class="caret"></span></a>
<ul class="dropdown-menu">
<li><a href="https://www.linuxcloudvps.com/clientportal/index.php?/tickets/">HelpDesk System</a></li>
<li><a href="https://www.linuxcloudvps.com/clientportal/index.php?/knowledgebase/">Knowledge Base</a></li>
</ul>
</li>
<li><a href="https://www.linuxcloudvps.com/blog/">Blog</a></li>
<li class="button"><a href="https://www.linuxcloudvps.com/clientportal/index.php?/clientarea/">Login</a></li>
</ul>
</div>
</div>
</nav>
</header>
<main class="main blog">
<div class="container">
<div class="row">
<div class="col-xs-12 col-sm-8">
<div id="content" role="main">
<article role="article" id="post_1740" class="post-1740 post type-post status-publish format-standard has-post-thumbnail hentry category-uncategorized tag-cmd tag-commands tag-firewall tag-linux">
<header>
<h2><a href="https://www.linuxcloudvps.com/blog/10-useful-firewall-cmd-commands-in-linux/">10 Useful firewall-cmd Commands in Linux</a></h2>
<p class="meta">
<time class="text-muted" datetime="30-07-2022">30th July 2022</time> /
Category: <a href="https://www.linuxcloudvps.com/blog/category/uncategorized/" rel="category tag">Uncategorized</a> /
Comments: <a href="https://www.linuxcloudvps.com/blog/10-useful-firewall-cmd-commands-in-linux/#comments">2</a> </p>
</header>
<section>
<div class="post-index-image">
<img width="742" height="372" src="https://www.linuxcloudvps.com/blog/wp-content/uploads/2022/07/10-useful-firewall-cmd-commands-in-linux.webp" class="attachment-post-thumbnail size-post-thumbnail wp-post-image" alt="10 useful firewall cmd commands in linux" srcset="https://www.linuxcloudvps.com/blog/wp-content/uploads/2022/07/10-useful-firewall-cmd-commands-in-linux.webp 742w, https://www.linuxcloudvps.com/blog/wp-content/uploads/2022/07/10-useful-firewall-cmd-commands-in-linux-470x236.webp 470w" sizes="(max-width: 742px) 100vw, 742px" /> </div>
<div class='heateorSssClear'></div><div class='heateor_sss_sharing_container heateor_sss_horizontal_sharing' data-heateor-sss-href='https://www.linuxcloudvps.com/blog/10-useful-firewall-cmd-commands-in-linux/'><div class='heateor_sss_sharing_title' style="font-weight:bold">Spread the love</div><div class="heateor_sss_sharing_ul"><a class="heateor_sss_facebook" href="https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Fwww.linuxcloudvps.com%2Fblog%2F10-useful-firewall-cmd-commands-in-linux%2F" title="Facebook" rel="nofollow noopener" target="_blank" style="font-size:32px!important;box-shadow:none;display:inline-block;vertical-align:middle"><span class="heateor_sss_svg" style="background-color:#3c589a;width:35px;height:35px;border-radius:999px;display:inline-block;opacity:1;float:left;font-size:32px;box-shadow:none;display:inline-block;font-size:16px;padding:0 4px;vertical-align:middle;background-repeat:repeat;overflow:hidden;padding:0;cursor:pointer;box-sizing:content-box"><svg style="display:block;border-radius:999px;" focusable="false" aria-hidden="true" xmlns="http://www.w3.org/2000/svg" width="100%" height="100%" viewBox="-5 -5 42 42"><path d="M17.78 27.5V17.008h3.522l.527-4.09h-4.05v-2.61c0-1.182.33-1.99 2.023-1.99h2.166V4.66c-.375-.05-1.66-.16-3.155-.16-3.123 0-5.26 1.905-5.26 5.405v3.016h-3.53v4.09h3.53V27.5h4.223z" fill="#fff"></path></svg></span></a><a class="heateor_sss_button_twitter" href="https://twitter.com/intent/tweet?text=10%20Useful%20firewall-cmd%20Commands%20in%20Linux&url=https%3A%2F%2Fwww.linuxcloudvps.com%2Fblog%2F10-useful-firewall-cmd-commands-in-linux%2F" title="Twitter" rel="nofollow noopener" target="_blank" style="font-size:32px!important;box-shadow:none;display:inline-block;vertical-align:middle"><span class="heateor_sss_svg heateor_sss_s__default heateor_sss_s_twitter" style="background-color:#55acee;width:35px;height:35px;border-radius:999px;display:inline-block;opacity:1;float:left;font-size:32px;box-shadow:none;display:inline-block;font-size:16px;padding:0 4px;vertical-align:middle;background-repeat:repeat;overflow:hidden;padding:0;cursor:pointer;box-sizing:content-box"><svg style="display:block;border-radius:999px;" focusable="false" aria-hidden="true" xmlns="http://www.w3.org/2000/svg" width="100%" height="100%" viewBox="-4 -4 39 39"><path d="M28 8.557a9.913 9.913 0 0 1-2.828.775 4.93 4.93 0 0 0 2.166-2.725 9.738 9.738 0 0 1-3.13 1.194 4.92 4.92 0 0 0-3.593-1.55 4.924 4.924 0 0 0-4.794 6.049c-4.09-.21-7.72-2.17-10.15-5.15a4.942 4.942 0 0 0-.665 2.477c0 1.71.87 3.214 2.19 4.1a4.968 4.968 0 0 1-2.23-.616v.06c0 2.39 1.7 4.38 3.952 4.83-.414.115-.85.174-1.297.174-.318 0-.626-.03-.928-.086a4.935 4.935 0 0 0 4.6 3.42 9.893 9.893 0 0 1-6.114 2.107c-.398 0-.79-.023-1.175-.068a13.953 13.953 0 0 0 7.55 2.213c9.056 0 14.01-7.507 14.01-14.013 0-.213-.005-.426-.015-.637.96-.695 1.795-1.56 2.455-2.55z" fill="#fff"></path></svg></span></a><a class="heateor_sss_button_linkedin" href="https://www.linkedin.com/shareArticle?mini=true&url=https%3A%2F%2Fwww.linuxcloudvps.com%2Fblog%2F10-useful-firewall-cmd-commands-in-linux%2F&title=10%20Useful%20firewall-cmd%20Commands%20in%20Linux" title="Linkedin" rel="nofollow noopener" target="_blank" style="font-size:32px!important;box-shadow:none;display:inline-block;vertical-align:middle"><span class="heateor_sss_svg heateor_sss_s__default heateor_sss_s_linkedin" style="background-color:#0077b5;width:35px;height:35px;border-radius:999px;display:inline-block;opacity:1;float:left;font-size:32px;box-shadow:none;display:inline-block;font-size:16px;padding:0 4px;vertical-align:middle;background-repeat:repeat;overflow:hidden;padding:0;cursor:pointer;box-sizing:content-box"><svg style="display:block;border-radius:999px;" focusable="false" aria-hidden="true" xmlns="http://www.w3.org/2000/svg" width="100%" height="100%" viewBox="0 0 32 32"><path d="M6.227 12.61h4.19v13.48h-4.19V12.61zm2.095-6.7a2.43 2.43 0 0 1 0 4.86c-1.344 0-2.428-1.09-2.428-2.43s1.084-2.43 2.428-2.43m4.72 6.7h4.02v1.84h.058c.56-1.058 1.927-2.176 3.965-2.176 4.238 0 5.02 2.792 5.02 6.42v7.395h-4.183v-6.56c0-1.564-.03-3.574-2.178-3.574-2.18 0-2.514 1.7-2.514 3.46v6.668h-4.187V12.61z" fill="#fff"></path></svg></span></a><a class="heateor_sss_button_pinterest" onclick="javascript:void( (function() {var e=document.createElement('script' );e.setAttribute('type','text/javascript' );e.setAttribute('charset','UTF-8' );e.setAttribute('src','//assets.pinterest.com/js/pinmarklet.js?r='+Math.random()*99999999);document.body.appendChild(e)})());" title="Pinterest" rel="nofollow noopener" style="font-size:32px!important;box-shadow:none;display:inline-block;vertical-align:middle"><span class="heateor_sss_svg heateor_sss_s__default heateor_sss_s_pinterest" style="background-color:#cc2329;width:35px;height:35px;border-radius:999px;display:inline-block;opacity:1;float:left;font-size:32px;box-shadow:none;display:inline-block;font-size:16px;padding:0 4px;vertical-align:middle;background-repeat:repeat;overflow:hidden;padding:0;cursor:pointer;box-sizing:content-box"><svg style="display:block;border-radius:999px;" focusable="false" aria-hidden="true" xmlns="http://www.w3.org/2000/svg" width="100%" height="100%" viewBox="-2 -2 35 35"><path fill="#fff" d="M16.539 4.5c-6.277 0-9.442 4.5-9.442 8.253 0 2.272.86 4.293 2.705 5.046.303.125.574.005.662-.33.061-.231.205-.816.27-1.06.088-.331.053-.447-.191-.736-.532-.627-.873-1.439-.873-2.591 0-3.338 2.498-6.327 6.505-6.327 3.548 0 5.497 2.168 5.497 5.062 0 3.81-1.686 7.025-4.188 7.025-1.382 0-2.416-1.142-2.085-2.545.397-1.674 1.166-3.48 1.166-4.689 0-1.081-.581-1.983-1.782-1.983-1.413 0-2.548 1.462-2.548 3.419 0 1.247.421 2.091.421 2.091l-1.699 7.199c-.505 2.137-.076 4.755-.039 5.019.021.158.223.196.314.077.13-.17 1.813-2.247 2.384-4.324.162-.587.929-3.631.929-3.631.46.876 1.801 1.646 3.227 1.646 4.247 0 7.128-3.871 7.128-9.053.003-3.918-3.317-7.568-8.361-7.568z" /></svg></span></a><a class="heateor_sss_button_reddit" href="https://reddit.com/submit?url=https%3A%2F%2Fwww.linuxcloudvps.com%2Fblog%2F10-useful-firewall-cmd-commands-in-linux%2F&title=10%20Useful%20firewall-cmd%20Commands%20in%20Linux" title="Reddit" rel="nofollow noopener" target="_blank" style="font-size:32px!important;box-shadow:none;display:inline-block;vertical-align:middle"><span class="heateor_sss_svg heateor_sss_s__default heateor_sss_s_reddit" style="background-color:#ff5700;width:35px;height:35px;border-radius:999px;display:inline-block;opacity:1;float:left;font-size:32px;box-shadow:none;display:inline-block;font-size:16px;padding:0 4px;vertical-align:middle;background-repeat:repeat;overflow:hidden;padding:0;cursor:pointer;box-sizing:content-box"><svg style="display:block;border-radius:999px;" focusable="false" aria-hidden="true" xmlns="http://www.w3.org/2000/svg" width="100%" height="100%" viewBox="-3.5 -3.5 39 39"><path d="M28.543 15.774a2.953 2.953 0 0 0-2.951-2.949 2.882 2.882 0 0 0-1.9.713 14.075 14.075 0 0 0-6.85-2.044l1.38-4.349 3.768.884a2.452 2.452 0 1 0 .24-1.176l-4.274-1a.6.6 0 0 0-.709.4l-1.659 5.224a14.314 14.314 0 0 0-7.316 2.029 2.908 2.908 0 0 0-1.872-.681 2.942 2.942 0 0 0-1.618 5.4 5.109 5.109 0 0 0-.062.765c0 4.158 5.037 7.541 11.229 7.541s11.22-3.383 11.22-7.541a5.2 5.2 0 0 0-.053-.706 2.963 2.963 0 0 0 1.427-2.51zm-18.008 1.88a1.753 1.753 0 0 1 1.73-1.74 1.73 1.73 0 0 1 1.709 1.74 1.709 1.709 0 0 1-1.709 1.711 1.733 1.733 0 0 1-1.73-1.711zm9.565 4.968a5.573 5.573 0 0 1-4.081 1.272h-.032a5.576 5.576 0 0 1-4.087-1.272.6.6 0 0 1 .844-.854 4.5 4.5 0 0 0 3.238.927h.032a4.5 4.5 0 0 0 3.237-.927.6.6 0 1 1 .844.854zm-.331-3.256a1.726 1.726 0 1 1 1.709-1.712 1.717 1.717 0 0 1-1.712 1.712z" fill="#fff" /></svg></span></a><a class="heateor_sss_more" title="More" rel="nofollow noopener" style="font-size: 32px!important;border:0;box-shadow:none;display:inline-block!important;font-size:16px;padding:0 4px;vertical-align: middle;display:inline;" href="https://www.linuxcloudvps.com/blog/10-useful-firewall-cmd-commands-in-linux/" onclick="event.preventDefault()"><span class="heateor_sss_svg" style="background-color:#ee8e2d;width:35px;height:35px;border-radius:999px;display:inline-block!important;opacity:1;float:left;font-size:32px!important;box-shadow:none;display:inline-block;font-size:16px;padding:0 4px;vertical-align:middle;display:inline;background-repeat:repeat;overflow:hidden;padding:0;cursor:pointer;box-sizing:content-box;" onclick="heateorSssMoreSharingPopup(this, 'https://www.linuxcloudvps.com/blog/10-useful-firewall-cmd-commands-in-linux/', '10%20Useful%20firewall-cmd%20Commands%20in%20Linux', '' )"><svg xmlns="http://www.w3.org/2000/svg" style="display:block;border-radius:999px;" width="100%" height="100%" viewBox="-4 -4 38 38"><circle cx="10" cy="15" r="3" fill="#fff"></circle><circle cx="20" cy="10" r="3" fill="#fff"></circle><circle cx="20" cy="20" r="3" fill="#fff"></circle><path d="M 10 15 L 20 10 m 0 10 L 10 15" class="heateor_sss_svg_stroke heateor_sss_no_fill" stroke-width="2" stroke="#fff"></path></svg></span></a></div><div class="heateorSssClear"></div></div><div class='heateorSssClear'></div>
<p>In this blog post, we are going to explain 10 useful firewall-cmd commands in Linux with real examples.</p>
<p>The firewall-cmd is the command-line client used to manage the runtime configurations. It is a firewall solution as an alternative to the iptables service. We know that a properly configured firewall is the only weapon that can defend the server from attacks caused by internal influences. The firewall-cmd is part of the firewalld application that can be used for managing the firewall.</p>
<p>In this blog post, we are going to use <a href="https://www.rosehosting.com/ubuntu-hosting/">Ubuntu 22.04 as Linux OS</a>. You can use any Linux distribution. Let&#8217;s get started!</p>
<span id="more-1740"></span>
<h2>Prerequisites</h2>
<ul><li>Fresh install of Ubuntu 22.04 OS</li><li>User privileges: root or non-root user with sudo privileges</li></ul>
<h2>Update the System</h2>
<p>Before we start with the firewall-cmd command we are going to update the system packages to the latest versions available.</p>
<pre class="wp-block-preformatted">sudo apt update -y &amp;&amp; sudo apt upgrade -y</pre>
<p>Once the system is updated we are ready to show you the basic firewall-cmd commands in Linux.</p>
<h2>1. Install Firewalld</h2>
<p>Let&#8217;s check what we will get if we execute the <strong>firewall-cmd</strong> command.</p>
<pre class="wp-block-preformatted"><a href="/cdn-cgi/l/email-protection" class="__cf_email__" data-cfemail="55273a3a21153d3a2621">[email&#160;protected]</a>:~# firewall-cmd
Command &#039;firewall-cmd&#039; not found, but can be installed with:
apt install firewalld
</pre>
<p>We can see that the <strong>firewall-cmd</strong> is not installed by default, so we will have to install it with the command provided in the output above.</p>
<pre class="wp-block-preformatted">sudo apt install firewalld</pre>
<p>Since the firewalld is a service, it will be automatically started after the installation, but if we want to be sure, we can start and enable it manually with the following commands:</p>
<pre class="wp-block-preformatted">sudo systemctl start firewalld &amp;&amp; sudo systemctl enable firewalld</pre>
<p>To check the status of the firewalld service, execute the following command:</p>
<pre class="wp-block-preformatted">sudo systemctl status firewalld</pre>
<p>You will receive the following output:</p>
<pre class="wp-block-preformatted"><a href="/cdn-cgi/l/email-protection" class="__cf_email__" data-cfemail="7b0914140f3b1314080f">[email&#160;protected]</a>:~# sudo systemctl status firewalld
● firewalld.service - firewalld - dynamic firewall daemon
     Loaded: loaded (/lib/systemd/system/firewalld.service; enabled; vendor preset: enabled)
     Active: active (running) since Wed 2022-07-06 18:34:51 UTC; 6min ago
       Docs: man:firewalld(1)
   Main PID: 1761 (firewalld)
      Tasks: 2 (limit: 4548)
     Memory: 24.8M
        CPU: 1.689s
     CGroup: /system.slice/firewalld.service
             └─1761 /usr/bin/python3 /usr/sbin/firewalld --nofork --nopid

Jul 06 18:34:50 host.test.vps systemd[1]: Starting firewalld - dynamic firewall daemon...
</pre>
<h2>2. Firewall-cmd Help Command</h2>
<p>The firewall-cmd help command will show us the syntax of the firewall-cmd, options, and usage.</p>
<pre class="wp-block-preformatted"><a href="/cdn-cgi/l/email-protection" class="__cf_email__" data-cfemail="097b66667d4961667a7d">[email&#160;protected]</a>:~# firewall-cmd --help

Usage: firewall-cmd [OPTIONS...]

General Options
  -h, --help           Prints a short help text and exists
  -V, --version        Print the version string of firewalld
  -q, --quiet          Do not print status messages

Status Options
  --state              Return and print firewalld state
  --reload             Reload firewall and keep state information
  --complete-reload    Reload firewall and lose state information
  --runtime-to-permanent
                       Create permanent from runtime configuration
  --check-config       Check permanent configuration for errors

Log Denied Options
  --get-log-denied     Print the log denied value
  --set-log-denied=
                       Set log denied value</pre>
<h2>3. Firewall-cmd List Services</h2>
<p>This command <strong>firewall-cmd &#8211;list-services</strong> will show us the enabled service on our system.</p>
<pre class="wp-block-preformatted"><a href="/cdn-cgi/l/email-protection" class="__cf_email__" data-cfemail="87f5e8e8f3c7efe8f4f3">[email&#160;protected]</a>:~# firewall-cmd --list-services
dhcpv6-client ssh
</pre>
<h2>3. Open Port with Firewall-cmd</h2>
<p>With this command, we can easily open a port on our server for incoming or outgoing connections.</p>
<pre class="wp-block-preformatted">sudo firewall-cmd --add-port=80/tcp

sudo firewall-cmd --add-port=443/tcp

sudo firewall-cmd --zone=public --add-port=3306/tcp
</pre>
<p>With these commands, we opened ports 80, and 443 for HTTP and HTTPS requests and port 3306 for MySQL service.</p>
<h2>4. List Open Ports with Firewall-cmd</h2>
<p>With this command, we can list the previously opened ports.</p>
<pre class="wp-block-preformatted"><a href="/cdn-cgi/l/email-protection" class="__cf_email__" data-cfemail="25574a4a51654d4a5651">[email&#160;protected]</a>:~# &lt;strong&gt;firewall-cmd --list-ports&lt;/strong&gt;
80/tcp 443/tcp 3306/tcp</pre>
<p>To make the new settings persistent, execute the following command:</p>
<pre class="wp-block-preformatted">sudo firewall-cmd --runtime-to-permanent</pre>
<h2>5. Closing Port with Firewall-cmd</h2>
<p>To close the port, for example, <strong>3306</strong> in Firewall-cmd execute the following command:</p>
<pre class="wp-block-preformatted">sudo firewall-cmd --remove-port=3306/tcp</pre>
<p>To make the new settings persistent, execute the following command:</p>
<pre class="wp-block-preformatted">sudo firewall-cmd --runtime-to-permanent</pre>
<p>Now, list the opened ports again:</p>
<pre class="wp-block-preformatted"><a href="/cdn-cgi/l/email-protection" class="__cf_email__" data-cfemail="691b06061d2901061a1d">[email&#160;protected]</a>:~# firewall-cmd --list-ports
80/tcp 443/tcp
</pre>
<p>As you can see, port 3306 is not on the list anymore./p&gt;</p>
<h2>6. List all zones with Firewall-cmd</h2>
<p>With this command, we can list all zones and information about them.</p>
<pre class="wp-block-preformatted">sudo firewall-cmd --list-all-zones

block
  target: %%REJECT%%
  icmp-block-inversion: no
  interfaces:
  sources:
  services:
  ports:
....

dmz
  target: default
  icmp-block-inversion: no
  interfaces:
  sources:
  services: ssh
 ....

home
  target: default
  icmp-block-inversion: no
  interfaces:
  sources:
  services: dhcpv6-client mdns samba-client ssh
  ports:
  protocols:
  forward: yes
  ....
</pre>
<h2>7. Firewall-cmd port forwarding</h2>
<p>To forward, for example, port 80 to port 443 on your server, you can use the following command:</p>
<pre class="wp-block-preformatted">sudo firewall-cmd --zone=public --add-forward-port=port=80:proto=tcp:toport=443 --permanent

sudo firewall-cmd --reload</pre>
<p>As you can see on all successfull commands, you will receive the <strong>success</strong> message.</p>
<pre class="wp-block-preformatted"><a href="/cdn-cgi/l/email-protection" class="__cf_email__" data-cfemail="01736e6e7541696e7275">[email&#160;protected]</a>:~# sudo firewall-cmd --zone=public --add-forward-port=port=80:proto=tcp:toport=443 --permanent
success
<a href="/cdn-cgi/l/email-protection" class="__cf_email__" data-cfemail="beccd1d1cafed6d1cdca">[email&#160;protected]</a>:~# sudo firewall-cmd --reload
success
</pre>
<h2>8. Access to Port from a specific IP address</h2>
<p>In this example, we are going to allow access to port 3306 only from IP 192.168.0.15</p>
<pre class="wp-block-preformatted">sudo firewall-cmd --permanent --zone=public --add-rich-rule &#039;rule family=&quot;ipv4&quot; source address=&quot;192.168.0.100&quot; port port=3306 protocol=tcp accept&#039;

sudo firewall-cmd --reload
</pre>
<h2>9. List all rules</h2>
<p>To list all rules, execute the following command:</p>
<pre class="wp-block-preformatted">sudo firewall-cmd --list-all</pre>
<p>If you follow all commands from the previous steps, you will receive the following output:</p>
<pre class="wp-block-preformatted"><a href="/cdn-cgi/l/email-protection" class="__cf_email__" data-cfemail="1b6974746f5b7374686f">[email&#160;protected]</a>:~# sudo firewall-cmd --list-all
public
  target: default
  icmp-block-inversion: no
  interfaces:
  sources:
  services: dhcpv6-client ssh
  ports: 80/tcp 443/tcp
  protocols:
  forward: yes
  masquerade: no
  forward-ports:
        port=80:proto=tcp:toport=443:toaddr=
  source-ports:
  icmp-blocks:
  rich rules:
        rule family=&quot;ipv4&quot; source address=&quot;192.168.0.100&quot; port port=&quot;3306&quot; protocol=&quot;tcp&quot; accept</pre>
<h2>10. Firewalld Man Command</h2>
<p>Finally, the last command will be the <strong>man</strong> for firewalld-cmd, which is very useful if you want to know everything about the firewalld. Execute the command <strong>sudo man firewall-cmd</strong>, and you will receive the following output:</p>
<pre class="wp-block-preformatted"><a href="/cdn-cgi/l/email-protection" class="__cf_email__" data-cfemail="afddc0c0dbefc7c0dcdb">[email&#160;protected]</a>:~# sudo man firewall-cmd
FIREWALL-CMD(1)                                                             firewall-cmd                                                            FIREWALL-CMD(1)

NAME
       firewall-cmd - firewalld command line client

SYNOPSIS
       firewall-cmd [OPTIONS...]

DESCRIPTION
       firewall-cmd is the command line client of the firewalld daemon. It provides an interface to manage the runtime and permanent configurations.

       The runtime configuration in firewalld is separated from the permanent configuration. This means that things can get changed in the runtime or permanent
       configuration.
</pre>
<p>That&#8217;s all. In this tutorial, we explained some basic firewalld-cmd commands that are very often used in the world of system administrators and other curious users. If you find it difficult to understand the basic firewalld-cmd commands, you can always contact our technical support, and they will do the rest for you. We are available 24/7.</p>
<p>If you liked this post about ten useful firewall-cmd commands in <a href="https://www.linuxcloudvps.com/">Linux</a>, please share it with your friends on the social networks using the buttons on the left or simply leave a reply below.</p>
<div class='heateor_sss_sharing_container heateor_sss_vertical_sharing heateor_sss_bottom_sharing' style='width:44px;left: -10px;top: 100px;-webkit-box-shadow:none;box-shadow:none;' data-heateor-sss-href='https://www.linuxcloudvps.com/blog/10-useful-firewall-cmd-commands-in-linux/'><div class="heateor_sss_sharing_ul"><a class="heateor_sss_facebook" href="https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Fwww.linuxcloudvps.com%2Fblog%2F10-useful-firewall-cmd-commands-in-linux%2F" title="Facebook" rel="nofollow noopener" target="_blank" style="font-size:32px!important;box-shadow:none;display:inline-block;vertical-align:middle"><span class="heateor_sss_svg" style="background-color:#3c589a;width:40px;height:40px;margin:0;display:inline-block;opacity:1;float:left;font-size:32px;box-shadow:none;display:inline-block;font-size:16px;padding:0 4px;vertical-align:middle;background-repeat:repeat;overflow:hidden;padding:0;cursor:pointer;box-sizing:content-box"><svg style="display:block;" focusable="false" aria-hidden="true" xmlns="http://www.w3.org/2000/svg" width="100%" height="100%" viewBox="-5 -5 42 42"><path d="M17.78 27.5V17.008h3.522l.527-4.09h-4.05v-2.61c0-1.182.33-1.99 2.023-1.99h2.166V4.66c-.375-.05-1.66-.16-3.155-.16-3.123 0-5.26 1.905-5.26 5.405v3.016h-3.53v4.09h3.53V27.5h4.223z" fill="#fff"></path></svg></span></a><a class="heateor_sss_button_twitter" href="https://twitter.com/intent/tweet?text=10%20Useful%20firewall-cmd%20Commands%20in%20Linux&url=https%3A%2F%2Fwww.linuxcloudvps.com%2Fblog%2F10-useful-firewall-cmd-commands-in-linux%2F" title="Twitter" rel="nofollow noopener" target="_blank" style="font-size:32px!important;box-shadow:none;display:inline-block;vertical-align:middle"><span class="heateor_sss_svg heateor_sss_s__default heateor_sss_s_twitter" style="background-color:#55acee;width:40px;height:40px;margin:0;display:inline-block;opacity:1;float:left;font-size:32px;box-shadow:none;display:inline-block;font-size:16px;padding:0 4px;vertical-align:middle;background-repeat:repeat;overflow:hidden;padding:0;cursor:pointer;box-sizing:content-box"><svg style="display:block;" focusable="false" aria-hidden="true" xmlns="http://www.w3.org/2000/svg" width="100%" height="100%" viewBox="-4 -4 39 39"><path d="M28 8.557a9.913 9.913 0 0 1-2.828.775 4.93 4.93 0 0 0 2.166-2.725 9.738 9.738 0 0 1-3.13 1.194 4.92 4.92 0 0 0-3.593-1.55 4.924 4.924 0 0 0-4.794 6.049c-4.09-.21-7.72-2.17-10.15-5.15a4.942 4.942 0 0 0-.665 2.477c0 1.71.87 3.214 2.19 4.1a4.968 4.968 0 0 1-2.23-.616v.06c0 2.39 1.7 4.38 3.952 4.83-.414.115-.85.174-1.297.174-.318 0-.626-.03-.928-.086a4.935 4.935 0 0 0 4.6 3.42 9.893 9.893 0 0 1-6.114 2.107c-.398 0-.79-.023-1.175-.068a13.953 13.953 0 0 0 7.55 2.213c9.056 0 14.01-7.507 14.01-14.013 0-.213-.005-.426-.015-.637.96-.695 1.795-1.56 2.455-2.55z" fill="#fff"></path></svg></span></a><a class="heateor_sss_button_linkedin" href="https://www.linkedin.com/shareArticle?mini=true&url=https%3A%2F%2Fwww.linuxcloudvps.com%2Fblog%2F10-useful-firewall-cmd-commands-in-linux%2F&title=10%20Useful%20firewall-cmd%20Commands%20in%20Linux" title="Linkedin" rel="nofollow noopener" target="_blank" style="font-size:32px!important;box-shadow:none;display:inline-block;vertical-align:middle"><span class="heateor_sss_svg heateor_sss_s__default heateor_sss_s_linkedin" style="background-color:#0077b5;width:40px;height:40px;margin:0;display:inline-block;opacity:1;float:left;font-size:32px;box-shadow:none;display:inline-block;font-size:16px;padding:0 4px;vertical-align:middle;background-repeat:repeat;overflow:hidden;padding:0;cursor:pointer;box-sizing:content-box"><svg style="display:block;" focusable="false" aria-hidden="true" xmlns="http://www.w3.org/2000/svg" width="100%" height="100%" viewBox="0 0 32 32"><path d="M6.227 12.61h4.19v13.48h-4.19V12.61zm2.095-6.7a2.43 2.43 0 0 1 0 4.86c-1.344 0-2.428-1.09-2.428-2.43s1.084-2.43 2.428-2.43m4.72 6.7h4.02v1.84h.058c.56-1.058 1.927-2.176 3.965-2.176 4.238 0 5.02 2.792 5.02 6.42v7.395h-4.183v-6.56c0-1.564-.03-3.574-2.178-3.574-2.18 0-2.514 1.7-2.514 3.46v6.668h-4.187V12.61z" fill="#fff"></path></svg></span></a><a class="heateor_sss_button_pinterest" onclick="javascript:void( (function() {var e=document.createElement('script' );e.setAttribute('type','text/javascript' );e.setAttribute('charset','UTF-8' );e.setAttribute('src','//assets.pinterest.com/js/pinmarklet.js?r='+Math.random()*99999999);document.body.appendChild(e)})());" title="Pinterest" rel="nofollow noopener" style="font-size:32px!important;box-shadow:none;display:inline-block;vertical-align:middle"><span class="heateor_sss_svg heateor_sss_s__default heateor_sss_s_pinterest" style="background-color:#cc2329;width:40px;height:40px;margin:0;display:inline-block;opacity:1;float:left;font-size:32px;box-shadow:none;display:inline-block;font-size:16px;padding:0 4px;vertical-align:middle;background-repeat:repeat;overflow:hidden;padding:0;cursor:pointer;box-sizing:content-box"><svg style="display:block;" focusable="false" aria-hidden="true" xmlns="http://www.w3.org/2000/svg" width="100%" height="100%" viewBox="-2 -2 35 35"><path fill="#fff" d="M16.539 4.5c-6.277 0-9.442 4.5-9.442 8.253 0 2.272.86 4.293 2.705 5.046.303.125.574.005.662-.33.061-.231.205-.816.27-1.06.088-.331.053-.447-.191-.736-.532-.627-.873-1.439-.873-2.591 0-3.338 2.498-6.327 6.505-6.327 3.548 0 5.497 2.168 5.497 5.062 0 3.81-1.686 7.025-4.188 7.025-1.382 0-2.416-1.142-2.085-2.545.397-1.674 1.166-3.48 1.166-4.689 0-1.081-.581-1.983-1.782-1.983-1.413 0-2.548 1.462-2.548 3.419 0 1.247.421 2.091.421 2.091l-1.699 7.199c-.505 2.137-.076 4.755-.039 5.019.021.158.223.196.314.077.13-.17 1.813-2.247 2.384-4.324.162-.587.929-3.631.929-3.631.46.876 1.801 1.646 3.227 1.646 4.247 0 7.128-3.871 7.128-9.053.003-3.918-3.317-7.568-8.361-7.568z" /></svg></span></a><a class="heateor_sss_button_reddit" href="https://reddit.com/submit?url=https%3A%2F%2Fwww.linuxcloudvps.com%2Fblog%2F10-useful-firewall-cmd-commands-in-linux%2F&title=10%20Useful%20firewall-cmd%20Commands%20in%20Linux" title="Reddit" rel="nofollow noopener" target="_blank" style="font-size:32px!important;box-shadow:none;display:inline-block;vertical-align:middle"><span class="heateor_sss_svg heateor_sss_s__default heateor_sss_s_reddit" style="background-color:#ff5700;width:40px;height:40px;margin:0;display:inline-block;opacity:1;float:left;font-size:32px;box-shadow:none;display:inline-block;font-size:16px;padding:0 4px;vertical-align:middle;background-repeat:repeat;overflow:hidden;padding:0;cursor:pointer;box-sizing:content-box"><svg style="display:block;" focusable="false" aria-hidden="true" xmlns="http://www.w3.org/2000/svg" width="100%" height="100%" viewBox="-3.5 -3.5 39 39"><path d="M28.543 15.774a2.953 2.953 0 0 0-2.951-2.949 2.882 2.882 0 0 0-1.9.713 14.075 14.075 0 0 0-6.85-2.044l1.38-4.349 3.768.884a2.452 2.452 0 1 0 .24-1.176l-4.274-1a.6.6 0 0 0-.709.4l-1.659 5.224a14.314 14.314 0 0 0-7.316 2.029 2.908 2.908 0 0 0-1.872-.681 2.942 2.942 0 0 0-1.618 5.4 5.109 5.109 0 0 0-.062.765c0 4.158 5.037 7.541 11.229 7.541s11.22-3.383 11.22-7.541a5.2 5.2 0 0 0-.053-.706 2.963 2.963 0 0 0 1.427-2.51zm-18.008 1.88a1.753 1.753 0 0 1 1.73-1.74 1.73 1.73 0 0 1 1.709 1.74 1.709 1.709 0 0 1-1.709 1.711 1.733 1.733 0 0 1-1.73-1.711zm9.565 4.968a5.573 5.573 0 0 1-4.081 1.272h-.032a5.576 5.576 0 0 1-4.087-1.272.6.6 0 0 1 .844-.854 4.5 4.5 0 0 0 3.238.927h.032a4.5 4.5 0 0 0 3.237-.927.6.6 0 1 1 .844.854zm-.331-3.256a1.726 1.726 0 1 1 1.709-1.712 1.717 1.717 0 0 1-1.712 1.712z" fill="#fff" /></svg></span></a><a class="heateor_sss_more" title="More" rel="nofollow noopener" style="font-size: 32px!important;border:0;box-shadow:none;display:inline-block!important;font-size:16px;padding:0 4px;vertical-align: middle;display:inline;" href="https://www.linuxcloudvps.com/blog/10-useful-firewall-cmd-commands-in-linux/" onclick="event.preventDefault()"><span class="heateor_sss_svg" style="background-color:#ee8e2d;width:40px;height:40px;margin:0;display:inline-block!important;opacity:1;float:left;font-size:32px!important;box-shadow:none;display:inline-block;font-size:16px;padding:0 4px;vertical-align:middle;display:inline;background-repeat:repeat;overflow:hidden;padding:0;cursor:pointer;box-sizing:content-box;" onclick="heateorSssMoreSharingPopup(this, 'https://www.linuxcloudvps.com/blog/10-useful-firewall-cmd-commands-in-linux/', '10%20Useful%20firewall-cmd%20Commands%20in%20Linux', '' )"><svg xmlns="http://www.w3.org/2000/svg" style="display:block;" width="100%" height="100%" viewBox="-4 -4 38 38"><circle cx="10" cy="15" r="3" fill="#fff"></circle><circle cx="20" cy="10" r="3" fill="#fff"></circle><circle cx="20" cy="20" r="3" fill="#fff"></circle><path d="M 10 15 L 20 10 m 0 10 L 10 15" class="heateor_sss_svg_stroke heateor_sss_no_fill" stroke-width="2" stroke="#fff"></path></svg></span></a></div><div class="heateorSssClear"></div></div> </section>
</article>
<h3>Feedback</h3>
<p class="text-muted" style="margin-bottom: 20px;">
<i class="glyphicon glyphicon-comment"></i>&nbsp; Comments: 2</p>
<ol class="commentlist">
<li class="comment even thread-even depth-1 parent" id="comment-28339">
<div id="div-comment-28339" class="comment-body">
<div class="comment-author vcard">
<div style="width: 60px; float: left;">
<img alt='' src='https://secure.gravatar.com/avatar/1bc2021e6ef733fcd741b0903070ffc6?s=40&#038;d=mm&#038;r=g' srcset='https://secure.gravatar.com/avatar/1bc2021e6ef733fcd741b0903070ffc6?s=80&#038;d=mm&#038;r=g 2x' class='avatar avatar-40 photo' height='40' width='40' loading='lazy' /> </div>
<div>
<h4 style="margin: 0 0 5px 0">William B Peckham</h4>
<p class="comment-meta commentmetadata"><a href="https://www.linuxcloudvps.com/blog/10-useful-firewall-cmd-commands-in-linux/#comment-28339">July 30, 2022 at 3:18 pm</a></p>
</div>
</div>
<div class="row">
<div class="col-sm-12">
<hr />
<p>The title is &#8220;10 useful firewall-cmd commands in Linux &#8220;, when it should be &#8220;10 useful firewall-cmd commands in Ubuntu&#8221;! These commands do not on any of my machines, because they have a different firewall installed and are not Ubuntu based. Ubuntu is only ONE Linux distribution, it is not Linux!</p>
</div>
</div>
<div class="reply">
<p class="text-right"> <a rel='nofollow' class='comment-reply-link' href='https://www.linuxcloudvps.com/blog/10-useful-firewall-cmd-commands-in-linux/?replytocom=28339#respond' data-commentid="28339" data-postid="1740" data-belowelement="div-comment-28339" data-respondelement="respond" data-replyto="Reply to William B Peckham" aria-label='Reply to William B Peckham'>Reply</a></p>
</div>
</div>
<ul class="children">
<li class="comment byuser comment-author-r0s3admin bypostauthor odd alt depth-2" id="comment-28348">
<div id="div-comment-28348" class="comment-body">
<div class="comment-author vcard">
<div style="width: 60px; float: left;">
<img alt='' src='https://secure.gravatar.com/avatar/?s=40&#038;d=mm&#038;r=g' srcset='https://secure.gravatar.com/avatar/?s=80&#038;d=mm&#038;r=g 2x' class='avatar avatar-40 photo avatar-default' height='40' width='40' loading='lazy' /> </div>
<div>
<h4 style="margin: 0 0 5px 0">admin</h4>
<p class="comment-meta commentmetadata"><a href="https://www.linuxcloudvps.com/blog/10-useful-firewall-cmd-commands-in-linux/#comment-28348">July 31, 2022 at 8:46 am</a></p>
</div>
</div>
<div class="row">
<div class="col-sm-12">
<hr />
<p>Thanks for noticing, we mentioned in the article that we will be using Ubuntu 22.04 OS in the first paragraphs.</p>
</div>
</div>
<div class="reply">
<p class="text-right"> <a rel='nofollow' class='comment-reply-link' href='https://www.linuxcloudvps.com/blog/10-useful-firewall-cmd-commands-in-linux/?replytocom=28348#respond' data-commentid="28348" data-postid="1740" data-belowelement="div-comment-28348" data-respondelement="respond" data-replyto="Reply to admin" aria-label='Reply to admin'>Reply</a></p>
</div>
</div>
</li>
</ul>
</li>
</ol>
<ul class="pagination">
<li class="older"></li>
<li class="newer"></li>
</ul>
<section id="respond">
<h3>Your feedback</h3>
<p><a rel="nofollow" id="cancel-comment-reply-link" href="/blog/10-useful-firewall-cmd-commands-in-linux/#respond" style="display:none;">Click here to cancel reply.</a></p>
<form action="https://www.linuxcloudvps.com/blog/wp-comments-post.php" method="post" id="commentform">
<div class="form-group">
<label for="author">Your name <span class="text-muted">(required)</span></label>
<input type="text" class="form-control" name="author" id="author" placeholder="Your name" value="" aria-required="true">
</div>
<div class="form-group">
<label for="email">Your email address(required, but will not be published) <span class="text-muted"></span></label>
<input type="email" class="form-control" name="email" id="email" placeholder="Your email address" value="" aria-required="true">
</div>
<div class="form-group">
<label for="comment">Your comment</label>
<textarea autocomplete="new-password" id="a3e83ee047" name="a3e83ee047" class="form-control" placeholder="Your comment" rows="8" aria-required="true"></textarea><textarea id="comment" aria-label="hp-comment" aria-hidden="true" name="comment" autocomplete="new-password" style="padding:0 !important;clip:rect(1px, 1px, 1px, 1px) !important;position:absolute !important;white-space:nowrap !important;height:1px !important;width:1px !important;overflow:hidden !important;" tabindex="-1"></textarea><script data-cfasync="false" src="/cdn-cgi/scripts/5c5dd728/cloudflare-static/email-decode.min.js"></script><script data-noptimize>document.getElementById("comment").setAttribute( "id", "aaeee2681d5e34a566ebe78d4c84c65a" );document.getElementById("a3e83ee047").setAttribute( "id", "comment" );</script>
</div>
<p><input name="submit" class="btn btn-default" type="submit" id="submit" value="Submit comment"></p>
<input type='hidden' name='comment_post_ID' value='1740' id='comment_post_ID' />
<input type='hidden' name='comment_parent' id='comment_parent' value='0' />
<div class="g-recaptcha" data-sitekey="6LeLc1sUAAAAAFjBEqiVoKnjFxmBTJYJbuoljkuY" data-theme="standard"></div><script type="text/javascript" src="https://www.google.com/recaptcha/api.js?hl=en"></script> <div id="recaptcha-submit-btn-area">&nbsp;</div>
<noscript>
            <style type='text/css'>#submit {display:none;}</style>
            <input name="submit" type="submit" id="submit-alt" tabindex="6"
                value="Submit Comment"/> 
            </noscript> </form>
</section>
</div>
</div>
<div class="col-xs-6 col-sm-4" id="sidebar" role="navigation">
<aside class="sidebar">
<section class="search-2 widget_search"><form class="form-inline" role="search" method="get" id="searchform" action="https://www.linuxcloudvps.com/blog/">
<input class="form-control" type="text" value="" placeholder="Search..." name="s" id="s" />
<button type="submit" id="searchsubmit" value="Search" class="btn btn-default"><i class="glyphicon glyphicon-search"></i></button>
</form></section>
<section class="recent-posts-2 widget_recent_entries">
<h4>Recent Posts</h4>
<ul>
<li>
<a href="https://www.linuxcloudvps.com/blog/10-useful-firewall-cmd-commands-in-linux/" aria-current="page">10 Useful firewall-cmd Commands in Linux</a>
</li>
<li>
<a href="https://www.linuxcloudvps.com/blog/how-to-install-matrix-synapse-on-ubuntu-20-04/">How to Install Matrix Synapse on Ubuntu 20.04</a>
</li>
<li>
<a href="https://www.linuxcloudvps.com/blog/how-to-install-vue-cli-on-ubuntu-20-04/">How to Install Vue CLI on Ubuntu 20.04</a>
</li>
<li>
<a href="https://www.linuxcloudvps.com/blog/how-to-install-code-server-ide-platform-on-ubuntu-20-04/">How to Install Code-Server IDE platform on Ubuntu 20.04</a>
</li>
<li>
<a href="https://www.linuxcloudvps.com/blog/how-to-install-and-use-php-composer-on-ubuntu-20-04/">How to Install and Use PHP Composer on Ubuntu 20.04</a>
</li>
</ul>
</section><section class="categories-2 widget_categories"><h4>Categories</h4>
<ul>
<li class="cat-item cat-item-207"><a href="https://www.linuxcloudvps.com/blog/category/guide/">Guide</a>
</li>
<li class="cat-item cat-item-206"><a href="https://www.linuxcloudvps.com/blog/category/how-to/">How To</a>
</li>
<li class="cat-item cat-item-3"><a href="https://www.linuxcloudvps.com/blog/category/linuxcloudvps/">linuxcloudvps</a>
</li>
<li class="cat-item cat-item-204"><a href="https://www.linuxcloudvps.com/blog/category/openssh/">OpenSSH</a>
</li>
<li class="cat-item cat-item-11"><a href="https://www.linuxcloudvps.com/blog/category/scripts/">Scripts</a>
</li>
<li class="cat-item cat-item-12"><a href="https://www.linuxcloudvps.com/blog/category/tips-and-tricks/">Tips and Tricks</a>
</li>
<li class="cat-item cat-item-13"><a href="https://www.linuxcloudvps.com/blog/category/tutorials/">Tutorials</a>
</li>
<li class="cat-item cat-item-208"><a href="https://www.linuxcloudvps.com/blog/category/ubuntu/">Ubuntu</a>
</li>
<li class="cat-item cat-item-212"><a href="https://www.linuxcloudvps.com/blog/category/ubuntu-18-04/">Ubuntu 18.04</a>
</li>
<li class="cat-item cat-item-205"><a href="https://www.linuxcloudvps.com/blog/category/ubuntu-20-04/">Ubuntu 20.04</a>
</li>
<li class="cat-item cat-item-1"><a href="https://www.linuxcloudvps.com/blog/category/uncategorized/">Uncategorized</a>
</li>
</ul>
</section></aside> </div>
</div>
</div>
<section class="promo">
<div class="container">
<div class="row text-center">
<h2>Sign up for a LinuxCloudVPS today</h2>
<a class="btn btn-primary btn-lg" href="https://www.linuxcloudvps.com/cloud-vps.html">Get Started Now</a>
</div>
</div>
</section>
</main>
<footer class="main-footer">
<div class="container">
<div class="row">
<div class="col-sm-2 menu">
<h3>Company</h3>
<ul>
<li>
<a href="https://www.linuxcloudvps.com/aboutus.html">About us</a>
</li>
<li>
<a href="https://www.linuxcloudvps.com/contact.html">Contact us</a>
</li>
<li>
<a href="/">Blog</a>
</li>
<li>
<a href="https://www.linuxcloudvps.com/clientportal/index.php?/tickets/">Support</a>
</li>
<li>
<a href="https://www.linuxcloudvps.com/speed-test.html">Speed Test</a>
</li>
</ul>
</div>
<div class="col-sm-3 menu">
<h3>Hosting Solutions</h3>
<ul>
<li>
<a href="https://www.linuxcloudvps.com/cloud-vps.html">Cloud VPS</a>
</li>
<li>
<li><a href="https://linuxcloudvps.com/clientportal/index.php?/affiliates/">Affiliate Program</a></li>
</li>
</ul>
</div>
<div class="col-sm-3 menu">
<h3>Linux Cloud Hosting</h3>
<ul>
<li>
<a href="https://www.linuxcloudvps.com/centos-cloud-vps.html">CentOS Cloud Server</a>
</li>
<li>
<a href="https://www.linuxcloudvps.com/ubuntu-cloud-vps.html">Ubuntu Cloud Server</a>
</li>
<li>
<a href="https://www.linuxcloudvps.com/debian-cloud-vps.html">Debian Cloud Server</a>
</li>
<li>
<a href="https://www.linuxcloudvps.com/arch-linux-cloud-vps.html">Arch-Linux Cloud Server</a>
</li>
<li>
<a href="https://www.linuxcloudvps.com/elastix-cloud-vps.html">Elastix Cloud VPS</a>
</li>
<li>
<a href="https://www.linuxcloudvps.com/opensuse-cloud-vps.html">OpenSUSE Cloud Server</a>
</li>
<li>
<a href="https://www.linuxcloudvps.com/scientific-linux-cloud-vps.html">Scientific Linux Cloud Server</a>
</li>
</ul>
</div>
<div class="col-sm-2 menu">
<h3>Other Services</h3>
<ul class="">
<li><a href="https://www.linuxcloudvps.com/clientportal/index.php/checkdomain/domain-registration#register">Domain Registration</a></li>
<li><a href="https://www.linuxcloudvps.com/clientportal/index.php/checkdomain/domain-registration#transfer">Domain Transfer</a></li>
<li><a href="https://www.linuxcloudvps.com/ssl-certificates.html">SSL Certificates</a></li>
</ul>
</div>
<div class="col-sm-2 menu">
<h3>Connect</h3>
<ul class="">
<li>
<a target="_blank" href="https://www.facebook.com/LinuxCloudVPS">Facebook</a>
</li>
<li>
<a target="_blank" href="https://twitter.com/LinuxCloudVPS">Twitter</a>
</li>
<li>
<a target="_blank" href="https://www.linkedin.com/company/linuxcloudvps-com">Linkedin</a>
</li>
</ul>
</div>
</div>
<div class="row credits">
<div class="col-md-6">
<p class="pull-left"><a href="https://www.linuxcloudvps.com/tos.html">Terms of Service</a> and <a href="https://www.linuxcloudvps.com/policies.html">other policies</a></p>
</div>
<div class="col-md-6">
<p class="pull-right">&copy; 2010-2017 Rose Web Services LLC</p>
</div>
</div>
</div>
</footer>

<script type="text/javascript">
            var sub = document.getElementById('submit');
            document.getElementById('recaptcha-submit-btn-area').appendChild (sub);
            document.getElementById('submit').tabIndex = 6;
            if ( typeof _recaptcha_wordpress_savedcomment != 'undefined') {
                document.getElementById('comment').value = 
                    _recaptcha_wordpress_savedcomment;
            }
            </script><script type='text/javascript' id='heateor_sss_sharing_js-js-before'>
function heateorSssLoadEvent(e) {var t=window.onload;if (typeof window.onload!="function") {window.onload=e}else{window.onload=function() {t();e()}}};	var heateorSssSharingAjaxUrl = 'https://www.linuxcloudvps.com/blog/wp-admin/admin-ajax.php', heateorSssCloseIconPath = 'https://www.linuxcloudvps.com/blog/wp-content/plugins/sassy-social-share/public/../images/close.png', heateorSssPluginIconPath = 'https://www.linuxcloudvps.com/blog/wp-content/plugins/sassy-social-share/public/../images/logo.png', heateorSssHorizontalSharingCountEnable = 0, heateorSssVerticalSharingCountEnable = 0, heateorSssSharingOffset = -10; var heateorSssMobileStickySharingEnabled = 1;var heateorSssCopyLinkMessage = "Link copied.";var heateorSssUrlCountFetched = [], heateorSssSharesText = 'Shares', heateorSssShareText = 'Share';function heateorSssPopup(e) {window.open(e,"popUpWindow","height=400,width=600,left=400,top=100,resizable,scrollbars,toolbar=0,personalbar=0,menubar=no,location=no,directories=no,status")}
</script>
<script type='text/javascript' src='https://www.linuxcloudvps.com/blog/wp-content/plugins/sassy-social-share/public/js/sassy-social-share-public.js?ver=3.3.42' id='heateor_sss_sharing_js-js'></script>
<script type='text/javascript' src='https://www.linuxcloudvps.com/blog/wp-content/themes/lcvps2015/js/bootstrap.min.js' id='bootstrap-js-js'></script>
<script type='text/javascript' src='https://www.linuxcloudvps.com/blog/wp-content/themes/lcvps2015/js/lcvps.js' id='wbst-js-js'></script>
<script type='text/javascript' src='https://www.linuxcloudvps.com/blog/wp-includes/js/comment-reply.min.js?ver=6.0.1' id='comment-reply-js'></script>
</body>
</html>
